Jump to content
43oh

Latest Energia not uploading to MSP430G22553


Recommended Posts

Get the error shown below when uploading. Seems to want an old usblib library??

I tried an old version of Energia (0101E0015) and it works fine !

 

I can also upload to a new MSP432 board in the new version without a problem.

 

--------

dyld: Library not loaded: /opt/local/lib/libusb-0.1.4.dylib
  Referenced from: /Users/ian/Downloads/Energia.app/Contents/Java/hardware/tools/msp430/bin/mspdebug
  Reason: image not found
An error occurred while uploading the sketch

----------

 

Platform is OSX 10.11.6

 

Any idea how to fix this?

 

TIA

Link to post
Share on other sites
  • 2 weeks later...

I've had a similar problem in a Windows 10 (x64) environment.

 

I'm a long time CCSv5.5 user, which is where I do almost all of my development. I use the MSP430G2 (with MSP430G2553 chip) and MSP430F5529 Launchpads.

 

Yesterday I downloaded Energia 1.6.10E18 to take advantage of some Arduino code that would fit into the 2553 MCU. It compiled ok, but every time I tried to upload from Energia into the 2553 on the launchpad, I got an upload error:

 

"usbutil: unable to find a device matching 0451:f432"

 

I see from this and other fora that the "usbutil" error is common with serial port configuration problems. But, my Energia 1.6.10E18 recognizes the Launchpad on the appropriate COM port under the Tools|Port menu. It's recognized in Windows|Device Manager|Ports as well. I have connectivity.

 

I am able to upload an LED blink program into the very same MSP430G2553 Launchpad with CCSv5.5. It works as expected. I am also able to upload an LED blink sketch into my MSP430F5529 Launchpad with the same Energia 1.6.10E18 application that fails with the MSP430G2553 Launchpad. The F5529 blinks away!

 

In sum, all the permutations and combinations of Launchpads, applications and MCUs that I use work as advertised with the sole exception of  Energia 1.6.10E18 uploading to MSP430G2553 Launchpad.

 

steeley had a similar problem using a different environment. His E15 version of Energia worked ok (-I did not attempt an earlier version) but E18 did not.

 

Something not quite right in the new Energia version?

 

Suggestions welcome.

 

Walter

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...