Jump to content

crt0.S not found

Recommended Posts

My OLIMEX-JTAG-ISO seems to be dead but fortunately I have a MK2 version.  I've not used it for debugging before and when I come to play with it this morning, I am getting an error message that I remember getting in the dim and distant past - unfortunately I can't remember how I solved it before on the MK1 model.


_reset_vector__() at crt0.S:118 0x1100

Can't find a source file at "/home/pf/git/msp430eclipse/dk.xpg.msp430eclipse/scripts/src/gcc/libgcc/config/msp430/crt0.S"

I had to upgrade my Eclipse plugin (from Ver1 to Ver3) and toolchain - everything compiles just fine.


Weirdly when I try to debug an old project, that does not show this problem - i.e. it just stops at main() as expected and yet it does not have a crt0.S file anywhere.


If anyone can point me in the right direction that would be much appreciated.

Share this post

Link to post
Share on other sites

Ok, got it working - I had set a couple of breakpoints in main.  Out of frustration, having tried everything else, I removed all breakpoints and relaunched and it worked ok - I can now add the breakpoints back in and all seems fine.  No idea what was wrong but something was screwy.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...