Jump to content

Strange voltage on RST pin msp430g2553 TSSOP 20 pin

Recommended Posts

Dear everyone,

I made six pcbs, but only one pcb well-worked.

I just wrote a program to test LED and Interrupt on button with LPM4.

My problem is only one pcb has about 3.3V on RST (well-worked), another about 2.2 to 2.8V.

The lower one only work for a short time, after that it turns to be uncontrolled.

I take off the chip and measure on RST pad (with out MCU), it is 3.3V.

So I hope your help to figure out where is my failure, why the RST pin was dropped voltage, was my MCU broke?

Please give me some suggestions to solve my problem.

Thank in advance!


Link to post
Share on other sites

Firstly, I can program the board, the code flashed without any error. I take off the chip and measure the pad, it is 3.3V, so the board can not be shorted. I face with 5 pcbs with same problem. I used a  soldering iron without adjustable heat. I wonder if the MCU was dead by overhead, but after all, I can flash the firmware so  ....

Link to post
Share on other sites

@@MSPLife - check for shorts and resistance differences anyway - many of us have been bitten before by similar issues.  I've had a few DOA ebay parts as well (odd resistor values, etc.).  I once had a short on a TSSOP that ended up being beneath the pins in a way that couldn't be clearly seen. 

It could be a fried MCU as well (a short between VCC and GND resolved when I pulled the chip off) - although I've never seen one that programmed correctly afterwards.

Link to post
Share on other sites

SOrry I got that backwards,


We tied reset to vcc through a 47k resistor.


Anyway, the datasheet or users guide. I forget which. States that you can leave reset float if you're using the on die watchdog. We found this to be incorrect. As our software was using the watchdog, with reset floating. The msp430 would not work until I put a 47k ohm resistor between reset and vcc.


I was getting odd, and inconsistent readings too. But it turns out the MSP430 was not even running, or if it were it was in a constant state of reset. I never checked with a scope.

Link to post
Share on other sites

My question is, if I can flashed firmware to MCU, was my MCU have ability to be dead?

I personally wouldn't rule it out.  Best advice I can give - rule out potential problems, one by one and don't make any assumptions that parts are viable (could be a bad LDO, especially if you're not 100% sure it's genuine)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...