Jump to content

Recommended Posts

I installed Energia on a Windows 10 computer.

I was careful to upload the Energia drivers .

Compiling Sketches went fast and easy, but uploading the compiled program did not work well.  I  got a lot of failures when I tried to upload. Maybe about one out of five uploads worked 


I repeated all the above on a different Windows 10 computer and got the same results. 


Finally I installed Enegia on a Windows 7 computer and everything worked perfect. 


The two Windows 10 computers were both Windows 7 and I used the Microsoft free upgrade package to install windows 10


 Can anyone comment on this or has anyone had a similar experience. 



Link to post
Share on other sites

What kind of errors?  I have Windows 10 Professional (laptop came with it preinstalled though) and no problems, but I will note I made sure to install all the TI drivers in signature-ignore mode (i.e. hold Shift while clicking the Restart menu option under Start>Power, select reboot to options menu, select option 7 after the reboot for booting with no driver signature verification, then install drivers in that special mode).  I did the same thing when I installed CCSv6 too.

Link to post
Share on other sites

I'm running Win10 x64 on this computer and am having no problems... other than the AP my Chronos watch has whose drivers are unsigned.


*edit- doing what @@spirilis mentioned, rebooting to allow installing the drivers without driver verification, then rebooting again and updating the driver for the device in question to point at the unsigned driver works.

Link to post
Share on other sites

Windows 10 works perfect for me too . . . Because I don't have it installed ;) Still on Win8 pro here, and wishing I stayed with Win7 pro . . .




By the way, I use the Energia provided mspdebug to upload code ( tilib -d USB --force-reset "prog $(PROJECT_DIR)$(TARGET_OUTPUT_FILE)" ) and it fails 1 in ~20 tries. Sometimes 2-3 time back to back. It never realy says what happened. Just gives an obscure fail code. But I always assumed it was a busy wait fail on the device.


I would imagine energia works around this by repeating until it no longer fails, but I honestly don't know . . .

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...