Jump to content
Sign in to follow this  
abecedarian

TI not supporting MSP-EXP430G2 on Mac or Linux?

Recommended Posts

It does seem strange but I have switched to doing G2xx development on a breadboard lately and then flashing with a F5529 LaunchPad. The breadboard and F5529 LP doesn't take long to set up and the F5529 LP emulator isn't as quirky.

Share this post


Link to post
Share on other sites

Yeah the G2 LP emulator is likely the reason. I don't recall what library in Windows supports the G2 emulator but the MSP Debug Stack (libmsp430.so, MSP430.dll in Windows) doesn't seem to in Linux IIRC.

Share this post


Link to post
Share on other sites

They made the decision early on.  It seems at some point they actually told people instead of keeping it quiet. I guess they hadn't decided.  Back in 2012 it was a miracle to even have linux support.  At that time all they said was: "The LaunchPad is not supported on Linux at this time." To me the implication was they might in the future.

 

https://e2e.ti.com/support/development_tools/code_composer_studio/f/81/p/171173/688729#688729

 

I can't find the thread where they finally said they would never support it but they did say it at one point.

 

[edit] I found the post .. from 2015 [/edit]

https://e2e.ti.com/support/development_tools/code_composer_studio/f/81/p/171173/1712768#1712768

Share this post


Link to post
Share on other sites

That's a bit odd, no?

Never really bothered me anyhow. I used, and will continue to use the gcc toolchain. Of course, I've never been a fan of CCS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×