Jump to content
43oh

Recommended Posts

Hi,

I used FR5969 to control the operation of CC1120. The chip transmit a packet periodically each second and after transmission completed, the chip goes into idle state.

 

When I just add a command strobe to enter the chip in sleep mode instead of idle state, the chip remain in TX state which is abnormal case. The user guide stated that any command will wake up the chip from sleep state.

 

 

post-46298-0-42608800-1462388264_thumb.png

 

post-46298-0-64565200-1462388270_thumb.png

Link to post
Share on other sites

Hi,

 

I had a similar problem with CC1120. It didn't want to go on Power Down mode when I strobe with "PWD" commannd.

 

Try to strobe with "IDLE" command before "POWERDOWN" strobe command. 

I did it without success. But I solved this problem after I figured out what happen.

 

When I retransmit the packet I just issued the STX command. PWD command reset the TX buffer, so you should load the buffer again before issuing the STX command after sleep.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...