Jump to content

Recommended Posts

I am using TM4C129 Launchpad launchpad and trying to connect XBee Series 2 (S2C) through UART. 


Looking into the pinout of TM4C129, I am connecting like below


XBee TX <---> RX (UART0)


XBee RX <---> TX (UART0)


XBee 3.3V <--->  pin#41


XBee GND <---> pin#62 


I use below code on the LaunchPad at Energia


void setup()
  //pinMode(13, OUTPUT);   

void loop()


And the below python code runs on my Mac as a coordinator



import serial

ser = serial.Serial('/dev/tty.usbserial-A104IC2U', 9600)

while True:
        incoming = ser.readline().strip()
        print '%s' % incoming

But it doesn't work. FYI, this code worked on Arduino.


Has anyone tried this before? Any suggestion?

Am I missing some connection? jumper settings? Anything on the code?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...