Jump to content

MSP430-GCC v4.0.1.0 with code composer studio

Recommended Posts

How do I get Code Composer Studio (mac beta version) to use the new compiler? I tried right clicking a project, Properties->General->Compiler version and  in the "Select Compiler Version" window selecting "Select new compiler from file-system" browsing to /Applications/ti/gcc/bin which contains msp430-elf-gcc and all the other goodies.

I however get an error message "No compiler selected! Please select a directory that contains the compiler for the MSP430 device-family."
Link to post
Share on other sites

BTW, the "Submit a comment" section appears to be broken. I tried using Safari, Chrome, and FF. Each time, the captcha was the same and each time I got the same error message "Error: Time limit is exhausted. Please enter CAPTCHA value again. Click the BACK button on your browser, and try again."


Either that or I got the math (8-x=4) wrong.

Link to post
Share on other sites

......    and from the ccs wiki  .....





MSP GCC 5.x not seen by CCS

MSP GCC compilers have an installation issue with CCS v6.1.2 and earlier where it will not properly register the 5.x msp gcc release. The 4.9 release will properly register and show as an available compiler version.

In order to fix this issue, save below xml file, MSP430_GNU_5.0.xml, to this location: <ccs>\ccsv6\eclipse\plugins\com.ti.ccstudio.buildDefinitions.GNU_6.1.1.201512151800\resources\buildDefinitions\msp430\

File:MSP430 GNU 5.0.zip

Restart CCS.

From your CCS project, update the compiler on the General tab to point to the new 5.x msp gcc release. Click ok. You should now see both msp gcc compiler versions as available choices.

The issue will be fixed in CCS 6.1.3 and CCS 6.2

Link to post
Share on other sites


Thanks for the information. I tried doing what you mentioned. I have a mac so the corresponding directory appears to be:



I placed the unzipped file there and restarted CCS. One thing I realized is that you don't get an error if you use the parent directory to bin, i.e.

/Applications/ti/gcc. Regardless, I tried both ways (/Applications/ti/gcc/bin (error re compiler not found) and /Applications/ti/gcc (no error)). Either way, GCC-5 does not appear.


Thanks once again. Hopefully the next CCS update will fix this issue.

Link to post
Share on other sites

I came across this the other day. I had issues on linux too. I was able to get it to appear by wiping out my $HOME/.ti directory and deleting the gcc 5 binary. Yes drastic but once I did that, then I could download the gcc 5 again and it worked properly. Note: wiping out your .ti directory is probably a bad idea

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...