Jump to content

Energia crashing -- java error -- SOLVED

Recommended Posts

This is solved.  See posts 7&8.  




I am on OS-X Yosemite 10.10.5


I updated to Energia-0101E0017


and the latest Java:

  java version "1.8.0_74"

  Java SE Runtime Environment (build 1.8.0_74-b02)

  Java HotSpot 64-Bit Server VM (build 25.74-b02, mixed mode)


Energia now crashes on start up, after its windows opens, with this error message: 

  Cannot launch Java application

  Uncaught exception in main method:

  java.lang.ArithmenticException: / by zero


Any one have any fixes for this?  


Thanks!  (I miss my energia)



Link to post
Share on other sites

One more thing you can try is to temporarily move all the libraries from your personal library folder (usually /Users/<username>/Documents/Energia) and try starting the IDE Again.

Another solution could be to edit /Users/<username>/Library/preferences.txt and remove all the last.sketchX.path and last.sketchX.location. Also change last.sketch.count to be 0 (last.sketch.count=0).



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...