Jump to content

Energia very slow after update to Windows 10

Recommended Posts

Here is my environment:

Windows 10 64
Energia 0101E0017
MSP430G2553 Launchpad version 1.5
I updated to Windows 10, downloaded and installed the drivers "EZ430-UART.zip" for the virtual serial port without an error message.
 When I plug in the Launchpad, it is recognised by the device manager as "USB serial device (COM11)". Under "Devices and printers" it is shown as "Texas Instruments MSP -FET43QUIF". 
Now, as long as the Launchpad is not yet plugged in, Energia works just fine.
However, if the Launchpad is already plugged in when I start Energia it takes forever until the following error message appears:
"Launch4j   An error occured while starting the application"
If you continue, the editor works normally, but the "Tools" menu reacts very, very slow (minutes!). But as soon as you unplug the Launchpad, the menu opens at once. The "Sketch" menu shows the same behaviour, but not always. To open a file takes for ever. Compilation proceeds normally, but nothing is uploaded!
If you start Energia before the Launchpad is plugged in, there is no error message, Energia works fine until you plug in the Lauchpad. Then the strange behaviour as above appears.
Well, it looks like a driver issue. Should I get another driver?
A little help would be appreciated, Daniel
Link to post
Share on other sites

The old operating system driver for the Launchpad FET is likely not compatible with Win10. Not sure that Win10 has a driver for the Launchpad in it's native drivers or that it would even recognize it properly. You may want to search the forum, using Windows 10 as the search term and see if anyone has found the Launchpad drivers for Win10.

Link to post
Share on other sites

I am banging my head and make slow progress.

I could pin down the bug to the Serial library, the Serial.print command. As long as my program does not use the UART  and Serial monitor, everything is fine. I can even initialize with "Serial.begin(9600)". 

I checked that the jumpers are set for "Hardware UART".

Downloading also works, so I am no more sure if it is a driver problem.


However, as soon as I send something with Serial.print from the Launchpad to the PC, Energia freezes for quit some time.

If I prevent the Launchpad to send data by pressing the reset button, everything is fine, no freeze.

If I program a button to send something, everything works fine until I press the button.

Therefore, the UART communication is somehow blocking Energia!


If I try to open the Serial monitor after a freeze I get the message:

"Serial port COM11 already in use. Try quitting any program that my be using it."


Therefore, it seems like download and Serial communication use different channels.


I also tried the same thing with Ubuntu on the same machine. I see the same behavior !!!

I also tried it with Windows 7 and it worked!! I also tried another Launchpad with no luck.


Any ideas?

cheers, Daniel

Link to post
Share on other sites

Many thank's for the replies!

But it goes from bad to worse.

I tried the TI driver, but now I can no more upload to the Launchpad at all. I get the message:


tilib: MSP430_Initialize: Could not find MSP-FET430UIF on specified COM port (error = 57)
tilib: device initialization failed
I deleted the driver, but this did not help. Interestingly, there is now a driver, Windows seems to have installed its own drivers
The Launchpad seems to be o.k. On another machine with Windows 7 everything works just fine.
any help is appreciated, Daniel
Link to post
Share on other sites

Hi Robert,

this is nice of you that you want look into it, your effort is really appreciated.

But let me tell what happend.

I was really fed up with Energia on Windows 10. I decided to install VirtualBox with Windows 7. Here, everything worked as it should! The only small problem was that is not always clear which OS gets the USB ports.

Having smelt blood, I went to a LINUX machine (Ubuntu) and tried my luck. After some newbie problems I succeeded in uploading to an MSP430 MPU. But it did still did not work for MSP432. However, on Ubuntu I did start Energia from a terminal (I still do not know how to do it otherwise) and got much more output than from Energia itself. And what you could read in a big heap of messages was, that the following file could not bee executed:


could not be executed. I checked and saw that this file had no execute permission. Changing this, hurra, it worked!!!! Why this permission was missing is beyond me.

Still not satisfied, I went back to the Windows 10 machine, installed Energia again, and it worked for 430 but not 432. Of course I checked the above file and found the missing execution permission. Fixed that and now it runs on Windows 10! Unfortunately on Windows 10 the trick with starting from a terminal to get more info does not work. So, without Ubuntu I would never have found the permission problem.

My only worry now is, that everything is stable.

Thank's a lot for your effort and I greatly appreciate that you bother for orther peoples problems, Daniel

Link to post
Share on other sites

I had similar problem.

Everything worked properly when my w7 got first updated to w10 (around July 2015)

but in December, w10 got new version (compilation 10586 I think)

and all TI drivers for 430, 5529, stellaris (and more specifically COM's) inside devices manager was yellow triangle on icons.

I try many times remove drivers and reinstall (with disabled driver signed chcecking) but without success :(

Fortunately I bought new ssd for system and after full w10 instalation and install (on clean system) TI drivers

everythig works OK now.

Link to post
Share on other sites

You have a problem.

Win10 Device Manager doesn't have a "Devices and Printers" node in the tree.


If the LP drivers are properly installed, you should have an entry under the "Ports (COM & LPT)" node listed as "MSP430 Application UART (COMx)", where 'x' is the Windows' mapped COM: port.


You might want to install CCS just to make sure you have the latest drivers.

Link to post
Share on other sites

Hi Robert,

My happiness did not last long. Next morning that old problems were back!!!!

Although it works fine with Win7 and Ubuntu, I gave it another try.

The culprit seems to be the serial line monitor. Here is a workaround I found:

Open some serial terminal, plug in the Launchpad and connect it to  the terminal (you need to guess the correct COM port).

Only now start Energia. Check if in the Energia preferences the serial line monitor is set to "false".

Now you can compile and download. This seems to work, although I did not yet had time to test it thoroughly.


There seems to be some unfinished business with Energia and Windows 10 (Microsoft seems to become some competition!). Maybe it is better to wait some time.

I also mention that I tried the "cloud" feature of CodeComposer Studio 6. If it works, this should let you compile and upload from the Cloud, what would be a blessing considering the monstrous CCS6. Here the software seems not have reached a stage to be realeased. It screw up my MSP432 repeatedly so badly that a factory reset of the firmware was necessary.

I also tried CCS6 on Win10 but also had troubles and decided to wait.


One last note. The old control panel is still available in Win10. There you can find the "Devices and Printers". I think what shows up there are the XDS110 drivers needed for MSP432.

Link to post
Share on other sites

Running Win10 here and no such problems as you suggest.


And now you mention MSP432? I thought your issue was G2553?



And no "Devices and Printers" in Win10 Device Manager:



Notice the two "MSP430 Application UART"?

One is a G2 Launchpad and the other is the access point for TI Chronos watch.


Docking in my MSP432 gives me:



Notice the "XDS110 Class" additions, one of which is "Application/User UART"? Those are the MSP432 things.


*edit- you might have to click on the images to get them to "blow up" so you can read them.

Link to post
Share on other sites

Hi abecedarian,

of course I want Energia to work with all MPU's I have, not only G2553.


Corncerning "Devices and Printers", your are barking up the wrong tree. As I already told, you must search for the "Control Panel", it is hidden in Win10, but it is there.

Oh, you mean "Devices and Printers" in "Control Panel", not in "Device Manager".

So this is something like you'd see: (note the icon at the bottom left)




I guess I need to figure some things out in order to help you but just a few days ago, I re-installed Win10 and got the system drivers loaded, then installed CCS and Energia and haven't had any problems.


The XDS thing is the debug interface and it also produces two entries for the MSP432 in Device Manager, one of which is "Application/User UART" and the other is "Auxiliary Data Port". The "Application/User UART" is the COM: port you should be connecting to with any serial term like Energia's built in or other so as to receive serial data from the device... provided you've instantiated the proper serial port on the MCU.


Energia itself should be able to find the port for uploading sketches and such. If it can't or won't, maybe check the "Auxiliary Data Port" has a COM: of less than 16- some things have issues with high COM: ports. You can change the COM: port in Device Manager settings.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...