Jump to content
43oh

Energia 17 not uploading


Recommended Posts

Hello,

 

I have been using Energia 16 for the last few weeks with everything working perfectly. Today I downloaded Energia 17, but it won't upload to Ti 432. I have installed the drivers and Energia 16 still works perfectly. I have tried it on two PC's with the same result. The software freezes at the upload stage ... see message below:

 

Thanks,

Zico.

 

Binary sketch size: 26351 bytes (of a 262144 byte maximum)
>>>> Done <<<<
xcopy C:\energia\energia-0101E0017\hardware\emt\ti\runtime\wiring\msp432\configPkg\package\cfg\energia_*.rov.xs . /Y 
C:\energia\energia-0101E0017\hardware\emt\ti\runtime\wiring\msp432\configPkg\package\cfg\energia_pm4fg.rov.xs
1 File(s) copied
 
Link to post
Share on other sites
  • 2 weeks later...

Hello, thanks for reply. Below is the error message I get when I try to upload:

 

C:\energia-0101E0017-windows\energia-0101E0017\tools\common\DSLite\common\targetdb\Modules\MSP432\MSP432_JSTATE_2_NotVisible.xml
Initializing: CS_DAP_0
Mapping registers: CS_DAP_0 - Core Registers
Mapping registers: CS_DAP_0 - Hidden
Building search data: CS_DAP_0
Executing Startup Scripts: CS_DAP_0
Initializing: CORTEX_M4_0
Mapping registers: CORTEX_M4_0 - Core Registers
Mapping registers: CORTEX_M4_0 - ADC14
Mapping registers: CORTEX_M4_0 - AES256
Mapping registers: CORTEX_M4_0 - CAPTIO0
Mapping registers: CORTEX_M4_0 - CAPTIO1
Mapping registers: CORTEX_M4_0 - COMP_E0
Mapping registers: CORTEX_M4_0 - COMP_E1
Mapping registers: CORTEX_M4_0 - COREDEBUG
Mapping registers: CORTEX_M4_0 - CRC32
Mapping registers: CORTEX_M4_0 - CS
Mapping registers: CORTEX_M4_0 - DIO
Mapping registers: CORTEX_M4_0 - DMA
Mapping registers: CORTEX_M4_0 - DWT
Mapping registers: CORTEX_M4_0 - EUSCI_A0
Mapping registers: CORTEX_M4_0 - EUSCI_A1
Mapping registers: CORTEX_M4_0 - EUSCI_A2
Mapping registers: CORTEX_M4_0 - EUSCI_A3
Mapping registers: CORTEX_M4_0 - EUSCI_B0
Mapping registers: CORTEX_M4_0 - EUSCI_B1
Failed: Operation was aborted
Mapping registers: CORTEX_M4_0 - EUSCI_B2
Mapping registers: CORTEX_M4_0 - EUSCI_B3
Mapping registers: CORTEX_M4_0 - FLCTL
Mapping registers: CORTEX_M4_0 - FPB
Mapping registers: CORTEX_M4_0 - FPU
Mapping registers: CORTEX_M4_0 - ITM
Mapping registers: CORTEX_M4_0 - MPU
Mapping registers: CORTEX_M4_0 - NVIC
Mapping registers: CORTEX_M4_0 - PCM
Mapping registers: CORTEX_M4_0 - PMAP
Mapping registers: CORTEX_M4_0 - PSS
Mapping registers: CORTEX_M4_0 - REF_A
Mapping registers: CORTEX_M4_0 - RSTCTL
Mapping registers: CORTEX_M4_0 - RTC_C
Mapping registers: CORTEX_M4_0 - SCB
Mapping registers: CORTEX_M4_0 - SCnSCB
Mapping registers: CORTEX_M4_0 - SYSCTL
Mapping registers: CORTEX_M4_0 - SYSTICK
Mapping registers: CORTEX_M4_0 - TIMER32
Mapping registers: CORTEX_M4_0 - TIMER_A0
Mapping registers: CORTEX_M4_0 - TIMER_A1
Mapping registers: CORTEX_M4_0 - TIMER_A2
Mapping registers: CORTEX_M4_0 - TIMER_A3
Mapping registers: CORTEX_M4_0 - TLV
Mapping registers: CORTEX_M4_0 - TPIU
Mapping registers: CORTEX_M4_0 - WDT_A
Mapping registers: CORTEX_M4_0 - Hidden
Building search data: CORTEX_M4_0
Executing Startup Scripts: CORTEX_M4_0
Connecting...
error: CS_DAP_0: Error connecting to the target: (Error -1040 @ 0x0) A firmware update is required for the debug probe. Click the "Update" button to update the firmware and connect to the debug target. DO NOT UNPLUG THE DEBUG PROBE DURING THE UPDATE. (Emulation package 6.0.14.5) 
fatal: CS_DAP_0: Error: (Error -265 @ 0x0) The firmware updater encountered an error and could not finish. Unplug and re-plug the XDS110, and try again. If the problem remains, try updating the firmware using the xdsdfu utility found in the .../ccs_base/common/uscif/xds110 directory of the CCS installation. View the ReadMe.txt file there for instructions. (Emulation package 6.0.14.5) 
Link to post
Share on other sites

Hello, this seems to have been fixed by using the CCS Cloud and following the above instructions, i.e. clicking the update button:

 

Once the update is is finished, Energia 17 works fine.

 

We have over 100 of these TI 432 boards that we are going to use in a project lab. Will I need to do this update on each board??

 

 

m_white.pngCS_DAP_0: Error connecting to the target: (Error -1040 @ 0x0) A firmware update is required for the debug probe. Click the "Update" button to update the firmware and connect to the debug target. DO NOT UNPLUG THE DEBUG PROBE DURING THE UPDATE. (Emulation package 6.0.14.5)
m_gray.pngMemory Map Initialization Complete
Link to post
Share on other sites

We traced it down to missing driver files.

Driver files have been updated on http://energia.nu/guide/guide_windows/

 

1: Please download the zip file here: http://energia.nu/files/xds110_drivers.zip

2: Reinstall the drivers

3: unplug/plug your launchpad

 

Upload using Energia. Windows should tell you that new drivers are being installed and update the firmware on the programmer automatically and upload the Sketch.

 

Robert

Link to post
Share on other sites

I am having problems with uploading too, just different error messages.  I installed the new drivers and get the same error message.  I thought I followed the installation instructions for Energia 17.  I have used previous versions of Energia with no issues.  Anyone have a suggestion on how to solve this?

 

Thanks,

John

 

 

***********************  Error message **********************

 

C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\common\Makefile:19: C:\Users\user1\Documents\Energia: Permission denied
C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\common\Makefile:19: 17\energia-0101E0017/hardware/msp432/variants/MSP_EXP432P401R/Board.mk: No such file or directory
CCROOT C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\tools\lm4f
SDKROOT C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\msp432/CC3200SDK_1.0.0.patch
C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\common\Makefile:94: C:\Users\user1\Documents\Energia: Permission denied
CLOSURE C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\common
MAINSKETCH MultiBlink.cpp
C:\Users\user1\Documents\Energia 17\energia-0101E0017\hardware\common\Makefile:94: 17\energia-0101E0017/hardware/msp432/Plat.mk: No such file or directory
'C:\Users\user1\Documents\Energia' is not recognized as an internal or external command,
operable program or batch file.
make: *** No rule to make target `17\energia-0101E0017/hardware/msp432/Plat.mk'.  Stop.
C:\Users\user1\Documents\Energia 17\energia-0101E0017\tools\common\bin\make returned 2
 

Link to post
Share on other sites

All,

  After totally reloading the latest drivers and Energia 17 I still cannot upload or compile, but I get a different error message.  It appears that a file called "clean" is missing from the drivers?  Any ideas what is missing and how to fix it?

 

  I have Windows 7 64 bit OS running on my laptop.

 

Thanks,

John

 

 

***************** error message from Energia 17

C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\tools\common\bin\make --no-print-directory -C C:\Users\user1\AppData\Local\Temp\build3924736852001100217.tmp\ -f C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\hardware\common\Makefile
CCROOT C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\hardware\tools\lm4f
SDKROOT C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\hardware\msp432/CC3200SDK_1.0.0.patch
CLOSURE C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\hardware\common
MAINSKETCH MultiBlink.cpp
#C:/Users/user1/Downloads/energia-0101E0017-windows/energia-0101E0017/tools/common/bin/make -C C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017/hardware/msp432/cores/msp432/driverlib clean
process_begin: CreateProcess(NULL, #C:/Users/user1/Downloads/energia-0101E0017-windows/energia-0101E0017/tools/common/bin/make -C C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017/hardware/msp432/cores/msp432/driverlib clean, ...) failed.
make (e=2): The system cannot find the file specified.

make: *** [driverlib] Error 2
C:\Users\user1\Downloads\energia-0101E0017-windows\energia-0101E0017\tools\common\bin\make returned 2

Link to post
Share on other sites

All,

  I tried the suggestion and moved the Energia directory to be in C:.  I get the same error, just with shorter directory names.  I am somewhat troubled to find a .tmp (C:\Users\user1\AppData\Local\Temp\build5110119268881189296.tmp) file being used somehow when Energia 17 is trying to compile.  Why isn't everything being sourced out of the directory created when the .zip was unpacked?

 

  Any clues or suggestions on how to solve this would be appreciated.

 

Thanks,

John

 

 

********************** Error message *****************************

 

C:\Energia17\tools\common\bin\make --no-print-directory -C C:\Users\user1\AppData\Local\Temp\build5110119268881189296.tmp\ -f C:\Energia17\hardware\common\Makefile
CCROOT C:\Energia17\hardware\tools\lm4f
SDKROOT C:\Energia17\hardware\msp432/CC3200SDK_1.0.0.patch
CLOSURE C:\Energia17\hardware\common
MAINSKETCH MultiBlink.cpp
#C:/Energia17/tools/common/bin/make -C C:\Energia17/hardware/msp432/cores/msp432/driverlib clean
process_begin: CreateProcess(NULL, #C:/Energia17/tools/common/bin/make -C C:\Energia17/hardware/msp432/cores/msp432/driverlib clean, ...) failed.
make (e=2): The system cannot find the file specified.

make: *** [driverlib] Error 2
C:\Energia17\tools\common\bin\make returned 2

Link to post
Share on other sites

There is an issue with compiling the driverlib from source. To fix this, uncheck "Compile DriverLib from source" in the Energia preferences.

Thank you, this solution worked perfectly.  However it is was not exactly obvious to a casual observer.  I am glad that the readers of this forum have the in depth knowledge to solve issues like this.  Thanks again.

 

John 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...