Jump to content
43oh

Energia E0016 not launching and general gripe


Recommended Posts

For the past 4 hours now I've been trying to get the latest version of ENERGIA to run and it will not.

 

I've installed the latest drivers for the launch pad.

 

no there are no spaces in the file path name.

 

I've installed latest version of java.

 

Fresh system restart after both.

 

all it does when you double click the icon is it shows the splash screen for 2 seconds then closes with no errors returned or nothing.

 

I can get energia E0015 to work though - so what's up with that?

 

on another note I see a few people on this forum have also had this issue:

http://forum.43oh.com/topic/8828-unable-to-open-enegia-0101e0016/

http://forum.43oh.com/topic/8610-energia-not-starting-on-windows-81/

 

both with no closure on them...is the problem being fixed? or you just dropping them like a hot rock?

 

oh and FYI, I've seen this link on so many replies and search hits as "please see our discussion pages..." : http://43oh.com/forum/viewforum.php?f=38 -YOU ARE AWARE IT'S A 404?

 

Link to post
Share on other sites

Hi @@Tron9000, welcome to the forum.

 

Energia is community led initiative. No one is dropping  threads like "a hot rock". We can offer suggestions as to what you might be missing.

I personally am not using Energia, but could you give some information on your build station - windows? 32, 64 bit? .. as it may help members to offer you suggestions.

 

oh and FYI, I've seen this link on so many replies and search hits as "please see our discussion pages..." : http://43oh.com/foru...wforum.php?f=38 -YOU ARE AWARE IT'S A 404?

Is this on the Energia page?

Link to post
Share on other sites

@@Tron9000 sorry to hear that you had a hard time to get this to work. We try our best to support everybody but we are a very small time and unfortunately won't always be able to get to all the threads. thanks for reporting back on the issue. Did you use the windows build in zip to unzip the Energia distribution? 

I have not seen this issue before. The only similar thing that I have seen was that the download was corrupt (partially downloaded) and hence missing files.

 

Thanks!

 

Robert

Link to post
Share on other sites

no problem, but you should update some of your pages like this one: http://energia.nu/guide/guide_windows/ as the link to the discussion page at the bottom is a 404.

 

Yes I used the the zip program that came with windows - seemed ok with E0015, it unzipped it no problem; But the E0016, seems it just didn't unzip some files and folders for whatever reason without any notification.

 

I then unzipped E0016 it with 7ZIP and it worked first time.

 

I didn't re-download E0016, so both process were carried out on the same zip-file, which kind of rules out any corruption on the file.

 

I think it's just windows, like with their USB file transfer system: I had a similar problem a while back where it was dropping packets of a file I was copying to a USB stick, used a 3rd party program and it fixed it.

Link to post
Share on other sites

On Windows, some things just don't like long directories, i.e. more than 255 characters in the path so Windows' built-in zip system might not work well for those. Haven't verified it though. NTFS doesn't have that limitation, but maybe Windows' zip does. However, I've not had any problems "opening" a zip in Explorer, then copy and paste the contents into a folder.

 

Having said that, I like 7-zip. I like the shell integration, which works even on Win10 / 64bit.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...