Jump to content
scotto18

MSP432 Windows XP drivers do not install correctly

Recommended Posts

I am trying to connect my MSP432 LP to a WIndows XP computer (having given up on using the Mac due to ongoing USB comms connection problems). I have downloaded and installed the driver package as instructed (XDS110_drivers.zip).

 

The driver installation says it was succesful however when I plug in the LP for the first time, installation of the TI debug probes driver(s) fail. The comm ports drivers install correctly.

 

During the driver installation these messages are shown:

 

"Cannot Install the Hardware

There was a problem installing this hardware:

XDS110 (02.02.04.00) with CMSIS-DAP

An error occured during the installation of the device

A service installation section in the INF is invalid"

 

Following this, in the Windows Device Manager, there are two devices listed as "XDS110 (02.02.04.00) with CMSIS-DAP", under "Texas Instruments Debug Probes", with yellow exclamation marks. Properties for both devices show that the driver is not installed. There are also 2 XDS110 COMM ports that are installed correctly.

 

I have tried this with two LP's, and two different XP computers and get the same result.

 

It therefore looks like there is a bug in the driver INF file somewhere.

 

Can anyone help? Am currently at a production standstill.

 

 

Scott

 

 

MORE INFO: when I try to upload a project in Energia16, I get the orange error message at the top of the console that says:

 

"the selected serial port Failed: Failed to evaluate GEL_Connect(). Connect failed does not exist or your board is not connected"

 

In the console it says:

 

"Failed: CS_DAP_0: Error connecting to the target: (Error -260 @ 0x0) An attempt to connect to the XDS110 failed. ... "

 

It then it goes on about firmware updates might be needed. I feel that the driver not installing correctly is more likely to be the problem and from other reading, updating the firmware seems like it may cause other problems.


In the

Edited by scotto18

Share this post


Link to post
Share on other sites

i have the same / similar problem with my 432 LP received last week.       PLEASE READ 'However...",  below......

 

 

EXCEPT :

 

>>>   - windows reports that the drivers were installed and that two 'XDS etc '  are ready to use      <<<

 

- there are yellow exclamation marks, as you describe, in device manager against two XDS

 

- Energia 16 - same reaction as you've described.

 

 

 

HOWEVER...

==========

 

When I run the 432 'CCS blink' program on CCS v6.1, the program compiles / loads / debugs (including breakpoints)...

 

....   all while widows still reports  two (2)  yellow exclamation points on the 2  XDS110 ....

 

 

 

 

 

Conditions:

=========

(vista / 32bit)

  ( silkscreen on the Launchpad PCB :   MSP--- rev 1.0   /   xds110-et   rev 1.0)

        (JTAG switch S101 'left' on XDS-ET)

             (the 432 LP  'out of box'with the blinking LEDs works OK.  )

 

 

 

 

//*****************************************************************************
//
// MSP432 main.c template - P1.0 port toggle
//
//****************************************************************************


#include "msp.h"


void main(void)
{
    volatile uint32_t i;


    WDTCTL = WDTPW | WDTHOLD;           // Stop watchdog timer


    // The following code toggles P1.0 port
    P1DIR |= BIT0;                      // Configure P1.0 as output


    while(1)
    {
        P1OUT ^= BIT0;                  // Toggle P1.0
        for(i=10000; i>0; i--);         // Delay
    }
}

 

 

 

 

 

I'm still investiging why this happens and how to fix it.

 

 

In the meanwhile - anybody have some other ideas ?

 

 

 

Cheers.

Share this post


Link to post
Share on other sites

Have you tried using "devmgmt.msc" to search the local hard drive(s) to locate the drivers?

 

Also, you don't say if 32 bit (x86) or 64 bit (x64)....

 

It's not that I can't locate the drivers - it's that they won't install successfully.

 

And its Windows XP 32 bit.

 

FWIW, have reloaded Energia16 on my Mac and it is now back to working OK - obviously my threat to try the beta CCS on the Mac was enough to pull Energia into line. So at least I am up and running.

 

Will continue to investigate XP driver problem.

 

Scott

Share this post


Link to post
Share on other sites

Have you already solved this issue?

I saw many possible workarounds (none working up to now).

 

I confirm that on a just installed WinXP Pro, at today the error

"XDS110 (02.02.04.01) with CMSIS-DAP

An error occured during the installation of the device

A service installation section in the INF is invalid"

is still present, and I really don't know how to solve it... (trying to play

a bit with SensorTags)

 

If anybody can reply with possible solutions, thank you very much!

 

 

P.S. @abecedarian: just installed the latest CCS from TI, without the LP attached to the computer

Share this post


Link to post
Share on other sites

@@Prakash73 - So the device shows in Device Manager but can't load the driver?

 

Some devices, while they appear to be a single device, install more than one driver when being installed and issues can arise where one step in the process fails but overall, it succeeds. This can lead to the error you've experienced- "A service installation section in the INF is invalid." In essence, a "service" the driver requires didn't install properly. Occasionally, this can be caused by something being installed by a "Standard" user instead of an "Administrator".

 

Maybe try right clicking on the affected device and select to update the device driver then select to browse for driver. Select the Windows' home drive, usually C:\, and make sure to include subfolders and let it look.

 

You might also go to Event Viewer and check the logs for things relating to the device in order to get more specific error details.

Share this post


Link to post
Share on other sites

FWIW, I did eventually solve this problem with the help of John Aldwinckle and now my MSP432's work fine on Windows XP.

 

The answer was given here on the TI forums:

 

http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/460560/1711065#1711065

 

In case the link above fails, here was the answer given by John:

 

 

I had a problem with the same symptoms and was able to resolve it. I don't guarantee that it will solve your problem.
My problem stems from:
1. The debug interface XDS110 with CMIS-DAP needs WinUSB
2. WinUSB is installed on Windows Vista and all subsequent versions of Windows, but not Windows XP
This is usually handled in Windows XP with a co-installer.
TI already has some files which look like they should co-install WinUSB, so I don't know what went wrong.

I was able to resolve it manually by using a program called zadig from http://zadig.akeo.ie/
The procedure I followed was:
1. Read the instructions on the web site. Read the usage guide.
2. Download the zadig program for Windows XP and run it. Do not download the program for Vista or later.
3. The program won't show you anything to change until you plug in the Launchpad
4. In the selection box of the program, choose XDS110 with CMIS-DAP (the first interface);
5. In the selection box of the program, choose XDS110 with CMIS-DAP (the second interface)
6. Exit the program
The device manager should say that both devices now have drivers.
Windows may want to re-install the driver if you plug the Launchpad into a different USB port.
The location for the driver on my installation is C:ti/ccsv6/ccs_base/emulation/windows/xds110_drivers/

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×