Jump to content
rando

MSP432 LP, and the EPB MK II examples for Energia?

Recommended Posts

All,

 

So disappointed today to see that the LCD checkout examples do not support the MSP432. Does anyone know of a simple sketch to exercise the LCD on the Education Booster-pack MK II, for the MSP432 ARM Launchpad?

 

I would run the CCS based projects, but the CCS update for the debug probe broke that today. :(.

 

Any help much appreciated!

 

Best,

 

R.

Share this post


Link to post
Share on other sites

Folks,

 

FYI, for anyone with the new LP MSP432, and MK II booster pack, form a Energia perspective, might be smart to wait awhile before purchasing. Doesn't seem quite supported yet!

 

R.

Share this post


Link to post
Share on other sites

Thanks all!

 

To be more specific, the Energia, EBP MK II samples,  shipped with v.16 do not support the graphic LCD found on the EPB MK II, for the new MSP432 LP. 

 

However there are example(s) for CCS, that ship within the support for the Education BoosterPack, as demonstrated aptly here.

 

https://www.youtube.com/watch?v=0BdCLLynk4Y, in the "Out of Box Demo"

 

I have a recently upgraded version of CCS 6.1, and I tried one of the Out of box demos on the  CCS Cloud (very very impressive business, CCS Cloud!)

 

Here's the error I have...

 

Error connecting to the target:
(Error -1063 @ 0x0)
Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver.
(Emulation package 6.0.14.5)

 

And in a similar vein for Energia 16 ...

 

Fatal: CORTEX_M4_0: Error connecting to the target: (Error -1063 @ 0x0) Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver. (Emulation package 5.1.641.0)
Failed: Failed to evaluate GEL_Connect(): Connect failed

 

 

I've tried reinstalling TI Emulators and downgrading to 6.0.14.0, without success. There was in attempt to upgrade the firmware on the the MSP432 LP I think, this may have failed?

 

R.

Share this post


Link to post
Share on other sites

Thanks all!

 

To be more specific, the Energia, EBP MK II samples,  shipped with v.16 do not support the graphic LCD found on the EPB MK II, for the new MSP432 LP. 

 

However there are example(s) for CCS, that ship within the support for the Education BoosterPack, as demonstrated aptly here.

 

https://www.youtube.com/watch?v=0BdCLLynk4Y, in the "Out of Box Demo"

 

I have a recently upgraded version of CCS 6.1, and I tried one of the Out of box demos on the  CCS Cloud (very very impressive business, CCS Cloud!)

 

Here's the error I have...

 

Error connecting to the target:

(Error -1063 @ 0x0)

Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver.

(Emulation package 6.0.14.5)

 

And in a similar vein for Energia 16 ...

 

Fatal: CORTEX_M4_0: Error connecting to the target: (Error -1063 @ 0x0) Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver. (Emulation package 5.1.641.0)

Failed: Failed to evaluate GEL_Connect(): Connect failed

 

 

I've tried reinstalling TI Emulators and downgrading to 6.0.14.0, without success. There was in attempt to upgrade the firmware on the the MSP432 LP I think, this may have failed?

 

R.

Try this fix in CCS. I used it to get mine working again, although another example in CCS 'broke' it again.

e2e.ti.com/support/microcontrollers/msp430/f/166/t/458680

Share this post


Link to post
Share on other sites

All,

 

This fault was corrected when in desperation, I tried to re-establish a link via a CCS session, with the EPB MKII off the board.

 

I was able to hit the reset button, on another example, debug correctly and then reattach the EPB MKII and run the FFT demo properly. So the error message regarding manually resetting the DAP debugger, via the reset button was correct.

 

Be advised, the FFT demo requires patching, the demo that ships in the examples, is broken fatally.

 

Best,

 

Randy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×