Jump to content
Oldnotdead

Windows 10 failure

Recommended Posts

Has anyone been successful with windows 10? I had been happily using energia 15 on my laptop using Windows 7.

I took the bait from Microsoft and installed windows 10. Everything I have tested so far is working okay. The only

program that is not working is Energia 15. I then downloaded Energia 16, but no luck. When I try and open Energia, I

Get the splash screen, then it freezes. After a long pause I get a windows message

Share this post


Link to post
Share on other sites

I have not tried Energia, but the test machine at work has had a number of issues with a variety of software. One of the students giuneapigged with Eclipse and had no end of trouble a few weeks ago, and ended up backing to win8. I don't know what the issue was, but I am not going to go to 10 for other reasons (license conditions among others)

Share this post


Link to post
Share on other sites

@@enl I agree with you on the license issues. I feel that they have made a mistake in the direction they are taking Windows. If they don't do some signifcant backtracking perhaps we will look back at this time and say "That was the beginning of the end for Windows".

Share this post


Link to post
Share on other sites

Working fine here. Win10 Build 10532 (Insider Preview 2nd release after RTM). Energia's been working fine for me since I entered the Insider program, by the way. Errors I've had have been my own fault.

 

post-26656-0-94054200-1442020211_thumb.jpg

 

I do, however, have Energia installed on a different hard drive though.

 

 

My suggestion might be to open the ZIP file, then extract everything into a folder on hard drive. If you download the zip and open it in Windows File Explorer, you'll see a folder titled "energia-0101E0016" and nothing else: double-click that folder to open it. Then click the "Extract All" button in the ribbon menu, and extract them to something like "[drive]:\E16\" so that under "E16", you have the following files and folders in that directory so the path name is as short as possible:

__MACOSX
drivers
examples
hardware
java
lib
reference
tools
cygiconv-2.dll
cygwin1.dll
energia.exe
libiconv-2.dll
libusb0.dll
revisions.txt
rxtxSerial.dll
Also, may not be related, but could be... what file system are you using where you're saving Energia? FAT32, exFAT, NTFS? And, do you have read/write/modify privilege to the folder you've extracted things to?

Share this post


Link to post
Share on other sites

@@enl I agree with you on the license issues. I feel that they have made a mistake in the direction they are taking Windows. If they don't do some signifcant backtracking perhaps we will look back at this time and say "That was the beginning of the end for Windows".

What licensing issues?

Share this post


Link to post
Share on other sites

Thank you all for the comments and suggestion. Still no luck. Here is what

I tried

 

1.  deleted the two versions of Energia that I had previously downloaded.

 

2. Downloaded Energia 16 and extracted the zip file to the suggested folder

  

Share this post


Link to post
Share on other sites

I don't think the file system has anything to do with it, should be completely transparent to applications like Energia. I suspect a borked TI driver somewhere.. Or Java install. You could go through installed programs and uninstall/reinstall anything from TI as well as Java JRE.

Share this post


Link to post
Share on other sites

@@chicken file system permissions could have something to do with it, but apparently that's not the case since extracting the files to the folder should give proper permissions on that folder in the NTFS system, but it is worth checking that folder's properties to ensure the user has those permissions. TI drivers could be an issue but those should only be called when trying to upload a program to the MCU. Re: Java - Energia carries with it an embedded Java runtime (JRE) so that shouldn't be an issue either since that's instantiated only when starting the "energia.exe" program.

 

My user permissions on my Energia install folder:

post-26656-0-95977800-1442080854_thumb.jpg

 

 

@@Oldnotdead : Trying @@chicken suggestion of uninstalling everything TI may be something worth pursuing.

Do you have a screen shot of the error window? Also, have you checked event viewer to see what might be happening?

You said E15 didn't work under 7- "The only program that is not working is Energia 15." Rolling back to 7 will probably not change that, and even then E16 might not work either. If you can, maybe try to backup the Win10 install so you can re-install that if the following doesn't work: in Win10 go to "Settings | Update & Security | Recovery | Reset this PC" and choose "Remove everything", which will essentially perform a clean install of Win10 (hence why I suggested making a backup of the current config you could roll back to). You could try "Keep my files", but that will do like it says, and keep things that might be affecting your system.

Share this post


Link to post
Share on other sites

@@Oldnotdead

A lot has changed from E12 to E16, besides the bug fixes additional boards have been added.

 

Anyhow, what are the permissions for the user "Mickey"? I assume that's you?
They should at least include "Read & Execute", "Read", "Write", and "Modify"; "List Folder Contents" should also be applied.

 

Are you in the "Administrator" group on this computer?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...