Jump to content

Win10 and Energia 16, upload fail

Recommended Posts



I have been using Energia 14 with C2000 launchpad F28027 on my laptop (Windows 8.1) successfully for some time. Coding, compiling, uploading, it all worked fine.

Then Microsoft suggested and offered an upgrade to Windows 10 version, and I accepted it. I also noticed a new version for Energia, so I downloaded Energia versions 15 and 16 and installed them. Now I can code and compile, but can not upload any more to C2000 launchpad. Energia 16 works fine until the message "Put switches in position...", and then reports "Upload failed" without an explanation at the console.

I checked the drivers, installed them again, followed the procedure described for XDS100 installation. Nothing.

Funny, I can still use the Energia 14 on this computer and upload sucessfully, but versions 15 and 16 do not want to upload. I have test-installed Energia 15 and 16 to several other computers with Windows 8 (we have lots of computers in the laboratory for students), and got the same result: it does not want to upload the compiled code on Windows 8, but uploads on computers with Windows 7.


I wonder if somebody has similar problems. Any idea on the solution of the problem? Thanks!





Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...