Jump to content
Forum sending old emails Read more... ×
Sign in to follow this  
ansh

UART using CC2650 sensorTag

Recommended Posts

Hi,

I am trying to send data through UART from MSP430G2553 to sensorTag CC2650 and then through Bluetooth we are seeong value on BLESCANNER app we are using SPPBLE server program but we are not getting any data on the app .Can any one help me out as i am still stuck on it..

Share this post


Link to post
Share on other sites

How are you attaching the G2553 UART to the sensortag2? Also I'd like to see the CC2650 firmware project too (is that the SPPBLE you mentioned? I'm not familiar with it)

 

Sent from my Galaxy Note II using Tapatalk

Share this post


Link to post
Share on other sites

Hi,

I am using pin 1.1 and pin 1.2 and have attached it to sensorTag 2 through DEVPACK slots given on it ,and yup it is SPPBLE server code  

Share this post


Link to post
Share on other sites

Are you using TI-RTOS to write the firmware for the SensorTag?

 

There's currently a bug in the board.c file in tirtos_simplelink_2_13_01_09\packages\ti\boards\SensorTag\CC26XXST_0120. The UART pins are mistakenly configured for a different CC26xx evaluation board (SRF06EB). The corrected version of the offending section is posted below, with the original version shown in the comments:

const UARTCC26XX_HWAttrs uartCC26XXHWAttrs[CC2650_UARTCOUNT] = {
    {    /* CC2650_UART0 */
        .baseAddr = UART0_BASE,
        .intNum = INT_UART0,
        .powerMngrId = PERIPH_UART0,
        .txPin = Board_DP5_UARTTX, // <-- originally "Board_EB_UART_TX,"
        .rxPin = Board_DP4_UARTRX, // <-- originally "Board_EB_UART_RX,"
        .ctsPin = PIN_UNASSIGNED,
        .rtsPin = PIN_UNASSIGNED
    },
};

EDIT: Wait a second... are you connecting the UART from the MSP430G2553 to those pins? They're already used by the Debug DevPack for the application UART backchannel. With the MSP430G2553 disconnected you can try using a terminal program on your PC to send/receive data between the PC and SensorTag. You can use PuTTY, or CCS has a terminal window under Window->Show View->Other...

Share this post


Link to post
Share on other sites

HI you guys :)

 

I am trying to connect a Lonet 808(gsm/gps) to my Sensor Tag(cc2650) via a groove connector mounted on the DevPack. I think this will make the ultimate IoT device :D

The first problem I am having is changing the Uart to use the SDA SCL as TX RX on groove3. As I can see, the hardware should allow for this change but my understanding of the software is not enough to figure out how to do this.

So my questions are:

 

1. How do I change which pins UART use for communication? (I am trying to modify the UART echo example)

2. Is there any limitations on how many different UART ports can be open at the same time?

 

I think my problem is related to Anshs' else please tell me and I will star a new thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×