Jump to content
Sign in to follow this  
Janos

Embedxcode Strange Errors When Using The Ethernet Library

Recommended Posts

Yesterday I found embedXcode and immediately liked the idea of the plugin. I just checked the demo Blink-Project which worked fine.

Now today I tried to write a simple program, containing Ethernet.h and EthernetUdp.h. For that I just included both files with #include <> and edited line 29 in the Makefile to APP_LIBS_LIST = Ethernet EthernetUDP

When I compile the Code, I get a lot of errors (28) from EthernetUdp.h like 'IPAdress' does not name a type or Type 'Print' is not a base type for type 'EthernetUDP'. I didn't change anything in these files and Energia compiles everything without any Problem and as far as I understood embedXcode just takes the same header files as Energia does, am I right?

 

I use OS X 10.10.3 with Xcode 6.4 and a TMC4C1294XL Launchpad

 

What could be the Problem here?

Share this post


Link to post
Share on other sites

Quick Update:

I tried the same code for an Arduino Project with embedXcode. This project compiles without any errors, so it seems to be Energia-specific.

 

One thing I noticed: After the first Build the Resources Group appears and is filled with Arduino/arduino, avr, sam. If I chose the TM4C129 Processor while creating a new project and run the first build, there is a Resources group, but it only contains c2000 and cc3200, not lm4f which should normally be the place to look for all these Headers my board needs if I interpreted everything right I read this evening ;)

Could this be a reason for my troubles an if so, how do I fix this issue?

Share this post


Link to post
Share on other sites

Hi Rei Vilo, thank you for the support.

 

I re-Installed Energia this morning. Then I created a new empty embedXcode project with user Library and compiled it for the first time without errors. After that I just included <Ethernet.h> and <EhternetUdp.h>. Xcode throws errors now while compiling, this time its something about SPI which was not declared in Project.cpp.

 

When I open the same .ino file from the project folder with Energia it compiles without problems.

I checked the projects Header Search Path in the Xcode, it looks as it should to me. Debug: Applications/Energia.app/Contents/Ressources/Java/hardware/lm4f/**, Release: Applications/Xcode.app/Contents/Developer... (my Xcode Window is to small for the complete path :D )

 

@@Rei Vilo:

I already searched in the knowledge Base for answers. Would you prefer me to open a support ticket over discussing it here?

Share this post


Link to post
Share on other sites

The Ethernet library has a sub-folder utility with no header files, so that folder isn't taken into account.

 

The Ethernet library also seems to be part of those very few libraries that require a certain order for the parameters to be respected.

 

The benefit of the Help Desk is that it allows to attach files and make support easier for me.

Share this post


Link to post
Share on other sites

Thank you!

 

I just opened a ticket, I didn't have the time for that since my last post. This is a really great support you give.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×