Jump to content

RedBear Labs WIFI mini CC3200 board, fails to upload

Recommended Posts

RedBear Labs WIFI mini CC3200 board


I tried compiling the blink example and it compiles fine, but fails to upload.


Tried using both Windows 7 32bit environment and Ubuntu 14.4 64bit environment.

I have installed all the required drivers on Windows.  I also had to copy the ftd2xx,dll to the folder where the C3200Prog.exe file is.


Received error on both platforms is :


Can't open device
Failed to open uart COM1
Could not open UART COM1

The board seems to work ok because I can connect to it via WIFI.


What do I need to do to upload the compiled file.  I would prefer a Linux solution.

Link to post
Share on other sites

My board has been working fine since fix from yesterday. Until now.

I created a wifi http server and added Serial.printlin("data") in the loop and I think it prints too often to allow the uploaderto trigger the bootloader. It keeps timing out and saying it could not trigger the bootloader.  Tried in both linux and windows.

Is their a way to FORCE erase my sketch from the CC3200 so that I can upload another without the println in the loop?

Link to post
Share on other sites
  • 6 months later...

Try holding down the reset button until it has been "uploading" for a second or two.  Tried on mine locally - flashes the device just fine.  Hopefully that's enough for it to start the bootloader.


this happens to me for the third time in a few days. energia 16 (MK20, win7 64) says "Upload Failed" . nothing else.

after many trials with the reset button the upload works again but it seems to me pretty random.


actually i though i would have solved this with an 20 sec delay before the loop() to prevent getting stuck with to fast Serial.println() etc.. but know i am stuck again.


Serial.println("20ms delay");

for(int i=0; i<10; i++){






the old sketch on the Wifi Mini still runs.

so what could i do ?


btw.  is the forum at rbl still alive ? my posts are not getting published since days. just two normal polite questions - this is superfrustrating !!!

Link to post
Share on other sites

now it seems blocked forever on windows 7 64bit ;-(

only "upload failed" but no message in the console

but i had a chance to try an upload in osx and linux. both work !!!

so it must be an windows driver problem probably with mbedWinSerial_16466.exe ? 

any idea how to solve / debug this ?

try another driver version ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...