Jump to content
Sign in to follow this  
tiaschaer

Installation of Energia with C2000 under Linux

Recommended Posts

Hi guys,

 

I am a newbie in the field and I just got a C2000 LaunchPad form a friend. I am using Arch Linux 32bit.

 

He suggested me to install Energia by following the instructions at:

http://energia.nu/pin-maps/guide_c2000launchpad/

The installation process worked without any problem, in fact I can start Energia and see the LaunchPad (C2000) under Tools/Board.

 

The problem is when I try to compile any example.

 

Example Basics/Blink:

<Linking>
error #10056: symbol "code_start" redefined: first defined in "core.a<F2802x_CodeStartBranch.S.o>"; redefined in "core.a<F2802x_asmfuncs.S.o>"
warning #10210-D: creating ".sysmem" section with default size of 0x400; use the -heap option to change the default size
"/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000//f2802x_common//cmd//F28027.cmd", line 118: error #10099-D: program will not fit into available memory.  placement with alignment/blocking fails for section "codestart" size 0x4 page 0.  Available memory ranges:
   BEGIN        size: 0x2          unused: 0x2          max hole: 0x2       
warning #10063-D: entry-point symbol other than "_c_int00" specified:  "code_start"
error #10010: errors encountered during linking; "Blink.cpp.out" not built

>> Compilation failure

Example
Basics/AnalogReadSerial:

>> Compilation failure
"AnalogReadSerial.ino", line 23: error #20: identifier "A3" is undefined
1 error detected in the compilation of "AnalogReadSerial.cpp".

I tried many different versions and combinations of Energia and C2000 Code Generation Tools (compiler) without success.

 

As a second option I also downloaded the C2000 branch of Energia from GitHub.

I can build it and start it but... it comes without the C2000 Board option. How can I get it in the menu Tools/Boards?

 

The third option was to download and install CCS6 and to specify the Energia path. I then imported the example Basics/Blink. Again, the compilation runs into an error:

Building file: /home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000/F2806x_common/source/F2806x_Adc.c
Invoking: C2000 Compiler
"/home/tia/localCompiled/energia-0101E0015_v15/hardware/tools/c2000/bin/cl2000" -v28 -ml -mt --include_path="/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000" --include_path="/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/variants/launchpad_f28027" --include_path="/home/tia/localCompiled/energia-0101E0015_v15/hardware/tools/c2000/include" -g --gcc --define=TMS320F28027 --define=F_CPU=60000000L --define=ARDUINO=101 --define=ENERGIA=13 --diag_warning=225 --display_error_number --diag_wrap=off --asm_extension=S --preproc_with_compile --preproc_dependency="F2806x_Adc.pp"  "/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000/F2806x_common/source/F2806x_Adc.c"
"/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000/F2806x_common/source/F2806x_Adc.c", line 12: fatal error #1965: cannot open source file "F2806x_Device.h"
1 catastrophic error detected in the compilation of "/home/tia/localCompiled/energia-0101E0015_v15/hardware/c2000/cores/c2000/F2806x_common/source/F2806x_Adc.c".
Compilation terminated.

Thanks a lot for your help!

Mattia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...