Jump to content
Sign in to follow this  
Pradeepa

Energia won't program the MSP-EXP430G2 Launchpad

Recommended Posts

Hello,

 

Today around 3~4 hours I have been trying to program my MSP-EXP430G2 launchpad using Energia. It looks like the FET in the board got bricked or something. 

 

When I connect the board to my Windows 8.1x64 machine it gets enumerated as the 'MSP430 Application UART (COM5)' which is good. But then when I use Energia to download a simple 'Blinky' example to the board it fails.

 

It says,

 

tilib: MSP430_Initialize: Could not find MSP-FET430UIF on specified COM port (error = 57)
tilib: device initialization failed
 
Also the device becomes 'Unknown USB Device (Device Descriptor Request Failed)' in the Device Manager. So it looks like the board tried to re-enumerate and failed to respond to USB Standard messages. I believe this is an issue in the FET which is populated in the board.
 
Is there any way to flash the FET in the MSP430 Launchpad? I tried 'LaunchPadFirmwareUpdater2.0.exe' to upgrade the firmware. But it is also not successful. It cannot detect the MSP430G2XXX device which is connected in the board. There also the device enumerates as an 'Unknown Device' too. 
 
I have Googled this issue for last couple of hours and could not find a solution. 
 
I think the FET firmware is messed up. So I'm trying to re-flash the MSP430F1612 to fix the issue. If anyone has tried this please let me know. If you have suggestions they are also welcome.
 
Cheers!!!

Share this post


Link to post
Share on other sites

I did some more digging on this matter. I checked the pin27 of the TUSB3410VF chip using a oscilloscope to see whether the clocks are properly coming. The CLK3410 signal is driven by the MSP430F16x chip and I wanted to check whether the firmware is running properly on that chip.

 

The result was as I expected. When I first connected the device to the PC I can see a 12 MHz square wave signal on PIN_49 of MSP430F16x chip. But as soon as Energia try to download the firmware to the device the clock gets disappeared. That's why the 'USB Device Not Recognized' message is coming.

 

So somehow during firmware download process I believe the FET firmware crashes. May be it's stuck in some ISR. I'm still checking on this.

 

Does anyone know what is the firmware inside the MSP430F16x chip?

 

Thanks.

Share this post


Link to post
Share on other sites

I tried to use CCS. There also the behavior is same. I'll try that application and see.

 

But I think it is a firmware issue. I'm trying to find the firmware of MSP430F16x chip and write it to the device.

Share this post


Link to post
Share on other sites

 

You can also try ELPtronic software to see if your board gets detected.

 

I tried the ELPtronic software. It does not say that it is connected. But when I try to read the Firmware version then I can see Device Manager getting refreshed and then I get 'Unknown USB Device' enumeration. 

 

Which is almost the same thing happened to me when I use Energia. I'll post a question in  TI forums and see whether I can get the FET firmware for the MSP430-G2 board. Then I can try to flash it through JTAG. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×