Jump to content
43oh

Can't find C2000 LaunchPad line item in CCS 5.2.1.00018


Recommended Posts

In the Users Guide for the LAUNCHXL-F28027 C2000 Piccolo LaunchPadExperimenter Kit

in section 3.3 Program and Debug the Temperature Measurement Demo Application it states:

 

"The project and associated source code for the C2000 Piccolo LaunchPad demo is included in the

controlSUITE software package and should automatically be found by the TI Resource Explorer in Code

Composer Studio v5. In the resource explorer, open the controlSUITE folder and then the kits tab and look

for the C2000 LaunchPad line item. Expand this item and select the LaunchPad Demo Application. Follow

the steps in the main pane of the resource explorer to import, build, debug, and run this application."

 

I just did (4-AUGUST-2012) a full install of CCS 5 and applied all updates. WHen I expand the Kits node under controlSSUITE I do not find the "C2000 LaunchPad line item". This is what I have (screen capture attached).

 

Am I missing something?

post-68-14264717201556_thumb.png

Link to post
Share on other sites

Hrmmm....looks like that broke somewhere during the release...

 

So, we changed some stuff about how resource explorer works, and one of the files must have gotten lost or not created by the installer. Looks like you are both using Windows 7, yes? I'll look into the matter and try to get an update out which fixes this.

 

In the mean time you can manually import projects by selecting File, Import, Existing CCS Projects. You can find all the LaunchPad information and examples in C:\TI\controlSUITE\development_kits\C2000 LaunchPad\.

Link to post
Share on other sites

Ok, I've resolved the issue with resource explorer. There was one wrong ID in the XML that was causing resource explorer to not pick up the XML. This new XML should fix the issue. You can copy it into c:\ti\controlSUITE\~cs_desktop\controlSUITE and replace the file that is already there. There will be a few other XML files there (libraries, kits, devices, root.content.xml), delete these files. Restart CCS, and you should have the C2000 LaunchPad entry in Resource Explorer.

 

I'm rolling these changes into an update, so if you don't feel like doing this manually just wait till tonight and update your controlSUITE.

resource_explorer_controlSUITE.xml

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...