Jump to content
43oh

Problem installing Bonescript on ubuntu


Recommended Posts

I can't seem to be able to install bonescript on my BBB. I'd appreciate any help. Thanks.

 
I installed ubuntu because I could not get HDMI to work with Angstrom even with the latest image.
 
The following is the output when I do "npm install bonescript" -
 
root@ubuntu-armhf:~# npm install bonescript
 
> bonescript@0.2.3 preinstall /root/node_modules/bonescript
> node-gyp clean || (exit 0); node-gyp configure build
 
make: Entering directory `/root/node_modules/bonescript/build'
  CXX(target) Release/obj.target/misc/misc.o
../misc.cpp:1:0: warning: "BUILDING_NODE_EXTENSION" redefined [enabled by default]
<command-line>:0:0: note: this is the location of the previous definition
../misc.cpp:21:27: error: variable or field ‘pollpri_event’ declared void
../misc.cpp:21:27: error: ‘EV_P_’ was not declared in this scope
../misc.cpp:21:46: error: expected primary-expression before ‘int’
../misc.cpp:32:5: error: ‘ev_io’ does not name a type
../misc.cpp:148:31: error: ‘EV_P_’ has not been declared
../misc.cpp:148:43: error: expected ‘,’ or ‘...’ before ‘*’ token
../misc.cpp: In static member function ‘static void Pollpri::Init(v8::Handle<v8::Object>)’:
../misc.cpp:37:34: warning: statement has no effect [-Wunused-value]
../misc.cpp:38:38: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:47:33: warning: statement has no effect [-Wunused-value]
../misc.cpp: In constructor ‘Pollpri::Pollpri()’:
../misc.cpp:51:49: warning: statement has no effect [-Wunused-value]
../misc.cpp:54:18: error: ‘event_watcher’ was not declared in this scope
../misc.cpp:54:46: error: ‘ev_init’ was not declared in this scope
../misc.cpp:56:9: error: ‘ew’ was not declared in this scope
../misc.cpp: In destructor ‘virtual Pollpri::~Pollpri()’:
../misc.cpp:60:48: warning: statement has no effect [-Wunused-value]
../misc.cpp:63:20: error: ‘EV_DEFAULT_’ was not declared in this scope
../misc.cpp:63:33: error: ‘event_watcher’ was not declared in this scope
../misc.cpp:63:46: error: ‘ev_io_stop’ was not declared in this scope
../misc.cpp: In static member function ‘static v8::Handle<v8::Value> Pollpri::New(const v8::Arguments&)’:
../misc.cpp:67:32: warning: statement has no effect [-Wunused-value]
../misc.cpp:84:49: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:84:55: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:84:73: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:88:53: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:88:73: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:93:56: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:93:60: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:93:63: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:93:83: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:99:43: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:99:47: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:99:64: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:102:48: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:102:52: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:102:55: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:102:74: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:105:22: error: ‘class Pollpri’ has no member named ‘ew’
../misc.cpp:105:32: error: ‘EV_READ’ was not declared in this scope
../misc.cpp:105:39: error: ‘ev_io_set’ was not declared in this scope
../misc.cpp:106:21: error: ‘EV_DEFAULT_’ was not declared in this scope
../misc.cpp:106:38: error: ‘ev_io_start’ was not declared in this scope
../misc.cpp:111:32: warning: statement has no effect [-Wunused-value]
../misc.cpp: In member function ‘void Pollpri::Event(Pollpri*, int)’:
../misc.cpp:117:57: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:117:61: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:117:67: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:118:23: error: ‘EV_READ’ was not declared in this scope
../misc.cpp:126:43: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:126:47: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:126:64: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:129:48: warning: left operand of comma operator has no effect [-Wunused-value]
../misc.cpp:129:52: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:129:55: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp:129:74: warning: right operand of comma operator has no effect [-Wunused-value]
../misc.cpp: In static member function ‘static void Pollpri::pollpri_event(int)’:
../misc.cpp:149:42: warning: statement has no effect [-Wunused-value]
../misc.cpp:150:44: error: ‘req’ was not declared in this scope
../misc.cpp:151:21: error: ‘revents’ was not declared in this scope
../misc.cpp:152:42: warning: statement has no effect [-Wunused-value]
../misc.cpp: In function ‘void init(v8::Handle<v8::Object>)’:
../misc.cpp:160:33: warning: statement has no effect [-Wunused-value]
make: *** [Release/obj.target/misc/misc.o] Error 1
make: Leaving directory `/root/node_modules/bonescript/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:267:23)
gyp ERR! stack     at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:789:12)
gyp ERR! System Linux 3.8.13-bone20
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "build"
gyp ERR! cwd /root/node_modules/bonescript
gyp ERR! node -v v0.10.19
gyp ERR! node-gyp -v v0.10.10
gyp ERR! not ok 
npm ERR! weird error 1
npm ERR! not ok code 0

 

Link to post
Share on other sites

Well, you should contact Jason Kridner on the beagleboard google groups. He is pretty active and usually answers such questions.

 

However, it almost seems you're missing dependencies.

 

and . . . 

 

../misc.cpp:21:46: error: expected primary-expression before ‘int’ <--- this seems to me as a rather odd error, But Id have to see the code( something which I dont really have time to look at )

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...