Jump to content
43oh

GDB complaints "no debugging symbols found"


Recommended Posts

Hi,

I am trying to learn debugging Stellaris launchpad using gcc. I am using the GCC arm embedded toolchain. And I am trying to debug the blinky example project in the stellarisware. But GDB complains that it can't find the debuggin symbols. I have tried defining the symbol "DEBUG" in the source code, but that failed. Please tell me how I can fix this issue?

Akhils-MacBook-Pro:blinky akhil$ arm-none-eabi-gdb gcc/blinky.axf 
GNU gdb (GNU Tools for ARM Embedded Processors) 7.6.0.20140731-cvs
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-apple-darwin10 --target=arm-none-eabi".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /Users/akhil/work/blinky/gcc/blinky.axf...(no debugging symbols found)...done.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...