Jump to content
43oh

Recommended Posts

Hi buddy,

I have a trouble, on both Stellaris and Tiva Lanchpad, PD0 and PB6 are joined through R9 0ohm resistor and PD1 and PB7 are joined through R10 0ohm resistor. Why is supplier do that ?. If I unsolder R9 and R10, will I face with any problems ?

Some case, PD0, PB6 not work properly because two resistors.

Thanks everyone!

Link to post
Share on other sites

This is done to allow certain functions to be accessed on certain boosterpack pins.

e.g. On the original launchpad (for the MSP430), pins 14 and 15 on the boosterpack had I2C signals SCL and SDA.

PD0 and PD1 provide those functions to those pins on the Tiva LP.

however those pins also had SPI functions MOSI and MISO.

PB6 and PB7 provide those functions to those pins on the Tiva LP.

See the Tiva launchpad manual (spmu296.pdf) Table 2-4, page 10.

 

If you remove the resistors then you will not be able to use the I2C functions on pins 14 and 15 (so if you have a booster pack that needs I2C there, you will have to

add some jumper wires, or install new resistors).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...