Jump to content

Kernel Panic under OSX 1.9.2 on Macbook Pro 2009

Recommended Posts


now I've updated OSX to 10.9.2, problems with serial port are solved, now I've another nasty problem:

On some circumstances I get kernel panic while uploading or even open energia with launchpad tiva connected. Under 10.6. i didn't have kernel panic once.


This problem also occurs on the the arduino IDE, but might be solved with 1.5.2 r2:

Fixed in 1.5.6 by replacing RXTX with JSSC


So do energia using RXTX or JSSC?


Here is the issue from github:



Link to post
Share on other sites
  • 1 month later...

Is there a workaround until the new version is released?

It´s really annoying to get a hard system crash every 5-10 times (even if only "check" and not "upload" a sketch). It amazed me, that I'm the only one with this issue with energia...

Link to post
Share on other sites
  • 2 weeks later...

..and the best thing of all:

even when you hit "save" or "save as" BEFORE upload and the system crashes, the sketch will  NOT be saved!

So under this circumstances I would pled, that Energia is NOT working under OSX Mavericks, at least for Macbooks pro 2009.

Link to post
Share on other sites
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...