Jump to content
madias

Energia 0101E0012 / TIVA TM4C123GXL / OSX 10.6.8 Serial port greyed out

Recommended Posts

Hello,

I'm completely new to Energia.

My new Launchpad shipped today and uploading example sketches works.

But in the IDE my serial port is greyed out.

I installed the included MSP430LPCDC 1.0.3b.pkg driver, restarted OSX, tried starting Energia with/without plugged launchpad, without result.

Either the search function for this problem gives no good result back.

So what is the trick using the Serial port on OSX for the serial monitor?

 

In system dialog following is showing up:

 

In-Circuit Debug Interface:

 

  Produkt-ID: 0x00fd

  Hersteller-ID: 0x1cbe  (Texas Instruments - Stellaris)

  Version: 1.00

  Seriennummer: 0E20B044

  Geschwindigkeit: Bis zu 12 MBit/s

  Hersteller: Texas Instruments

  Standort-ID: 0x06200000 / 4

 

Thanks

Matthias 

Share this post


Link to post
Share on other sites

Meanwhile I tried everything out as in other threads written, like using an old lm4flash version, without success... uploading is no problem, but the serial monitor isn't working, because there is no tty/cu device, so I think this must be a driver problem (like creating a virtual com port device)

Share this post


Link to post
Share on other sites

Welcome to the forum!

 

Am I understanding you correctly in that you are experimenting with Energia but don't actually have your hardware yet?

 

If so, with Windows the port doesn't show up until the hardware has been plugged in and has enumerated.  As I am not a Linux expert by any means I am not sure if Linux behaves the same way with USB hardware.

Share this post


Link to post
Share on other sites

Hello,

I'm sorry, you misunderstood me, because of my spelling, I meant:

My Launchpad has been delivered today and I'm working with it. I can successfully upload sketches, but there is no serial monitor, because the "serial port" menu is grayed out. There are some threads about this problem, but without a clear solution for OSX.

Share this post


Link to post
Share on other sites

I misunderstood lots....OSX isn't Linux.  :unsure:

 

Note to myself....slow down and read the post carefully.

 

I am afraid I won't be of much help with OSX either.  Hopefully someone who is will jump in and lend a hand.

Share this post


Link to post
Share on other sites

Hi,

I do not have experience with OSX 10.6.8 - I use 10.7.5 (L) - and for TI - Stellaris /Tiva processors worked for me the following:

1) USB prober to find out everything about a particular board/interface attached to USB port

2) In terminal window, you may try this:

ls /dev/tty.usbmodem* to list all devices - TI boards shows as /dev/tty.usbmodem0xxxxxxxx, where 0xxxxxxxx is the serial number of the board, in hex. Note: other boards do not shows that (e.g STM32 Discovery, but is detected by USB Prober).

Also for TI boards, /dev/cu.usbmodem0xxxxxxxx was found.

I managed to use these boards as native in Eclipse, no other particular driver was needed (both for OpenOCD and icdi-flash program).

L

Share this post


Link to post
Share on other sites

Hi,

I´ll tried it out at home with USB prober, but I suspect, there is a compatibilty problem with OSX 10.6.x, so there is no /dev/cu.usbmodemxxx...

Share this post


Link to post
Share on other sites

energia: Yes, you understood everything right!

Ok, i tried out following things:

Installed energia 0101E0012 on my Hackintosh instead of using my macbook-pro, sadly the same OSX 10.6.8. running:

Connect the EK-TM4C123GXL without installing everything:

No modem under /dev

Under system profiler-> USB tree:

 In-Circuit Debug Interface

  Produkt-ID: 0x00fd

  Hersteller-ID: 0x1cbe  (Luminary Micro Inc.)

  Version: 1.00

  Seriennummer: 0E20B044

  Geschwindigkeit: Bis zu 12 MBit/s

  Hersteller: Texas Instruments

  Standort-ID: 0x1d100000

  Verfügbare Stromstärke (mA): 500

  Erforderliche Stromstärke (mA): 250

 

then:

Installed energia and MSP430LPCDC 1.0.3b.pkg

reboot

same results! I can upload sketches without problems, but no serial monitor/port/modem whatever.

 

Now some results from usb prober:

 

Kernel extensions:

com.apple.iokit.IOUSBFamily      3.8.5      188 KB      184 KB      0x7fd77000
com.apple.driver.AppleUSBEHCI      3.7.5      80 KB      76 KB      0x7fcbb000
com.apple.driver.AppleUSBUHCI      3.7.5      64 KB      60 KB      0x7fccf000
com.apple.iokit.IOUSBUserClient      3.8.5      8 KB      4 KB      0x7fbbd000
com.apple.driver.AppleUSBHub      3.8.4      60 KB      56 KB      0x7fe4c000
com.apple.driver.AppleUSBComposite      3.7.5      16 KB      12 KB      0x802f3000
com.apple.driver.AppleUSBMergeNub      3.8.5      12 KB      8 KB      0x80325000
com.apple.driver.AppleUSBBluetoothHCIController      2.4.0f1      44 KB      40 KB      0x803ab000
com.apple.iokit.IOUSBHIDDriver      3.8.4      24 KB      20 KB      0x8039f000
com.apple.driver.AppleUSBHIDKeyboard      141      8 KB      4 KB      0x80315000
com.apple.driver.AppleUSBAudio      2.7.6f4      192 KB      188 KB      0x808a4000
com.Ralink.driver.RT2870USBWirelessDriver      4.1.0      616 KB      612 KB      0x80a64000
com.parallels.kext.prl_usb_connect      6.0 11994.637263      24 KB      20 KB      0x79ae6000
com.apple.driver.AppleUSBCDCACMControl      4.0.2      12 KB      8 KB      0x79b3d000
com.apple.driver.AppleUSBCDCACMData      4.0.2      28 KB      24 KB      0x805f7000
com.apple.driver.AppleUSBCDCECMData      4.0.2      20 KB      16 KB      0x805f2000
 
I/O registry:
       AppleUSBUHCI  <class AppleUSBUHCI>
           1: UHCI Root Hub Simulation@1D  <class IOUSBRootHubDevice>
           2: ReMOTE SL Compact@1d200000  <class IOUSBDevice>
           3: In-Circuit Debug Interface@1d100000  <class IOUSBDevice>
               IOUSBCompositeDriver  <class IOUSBCompositeDriver>
               IOUSBInterface@0  <class IOUSBInterface>
               IOUSBInterface@1  <class IOUSBInterface>
               IOUSBInterface@2  <class IOUSBInterface>
               IOUSBInterface@3  <class IOUSBInterface>
 
ls /dev/tty.usbmodem* : nothing found!
 
So I think on OSX 10.6.x we need a kernel extension or something.
 
Edit:
I tried the same things out with my new TM4C1294XL launchpad - same results!
Edited by madias

Share this post


Link to post
Share on other sites

...so no hints getting the serial monitor working under osx10.6.8?

As a "workaround" I use my old arduino UNO as serial-port sniffer getting the serial signal from launchpad and gives me over usb into the serial monitor...

Share this post


Link to post
Share on other sites

Thank you for your answer Rei!

Meanwhile there are more pros than cons updating to 10.9., so I ordered a new SSD for my macbook yesterday for a fresh install...

I'll report the results in this forum.

If it´s really a problem of Snow Leopard, a comment in the release note of energia ("OSX 10.6. not supported") would be nice if other people have the same problems.

Share this post


Link to post
Share on other sites

Ok, back with a new fresh SSD and with OSX Mavericks (10.9.2., didn't do the update) on it, I give following report:

 

  • Serial port now works.
  • So the serial port isn´t working under OSX 10.6.x
  • There might be a problem, if you connect the launchpad first and THEN start energia, it could happend, that the serial port isn´t found. So do everytime:
  • Start energia first.
  • Connect the launchpad secondary.

 

Maybe a little relase note for the OSX distribution will be fine with my workaorunds (serial port under 10.6.x not availabile, start energia first)

 

regards

Matthias

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...