Jump to content
43oh

Very simple question - using "NOOP"


Recommended Posts

Hi,

 

Some comments first:
In general, depends on tool chain - some usual tools have a syntax like this:
__asm("        nop\n");
The space before instruction is a TAB for some toolchains - take care.
And some other comments (from ARM manual): 
NOP does nothing - and is not necessarily a time-consuming NOP. The processor might remove it from the pipeline before it reaches the execution stage. Can usually used for padding, for example to place the following instruction on a 64 bit boundary.
L.
Link to post
Share on other sites
In the first time that I used "_nop_()", the command not worked and the CCS jumped the break point, but now worked well.

 

One new question, when I started a new project (with StellarisWare) appears one warning "#10210-D creating ".stack" section with default size of 0x800; use the -stack option to change the default size". This warning doesn't appeared on the first test, what it means?

 

I used this site as a guide for using the StellarisWare: hackaday.com/2012/10/14/using-stellarisware-with-the-launchpad/

 

Thanks for the help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...