Jump to content
Christoph

linux: Eclipse + CodeSourcery + STlink

Recommended Posts

Well hello,

this forum seems to be new (??) but you guys seem to be hanging out here quite a lot.

 

I guess I am dumb... I have been trying to get my programming environment running for a .... long time by now. Each time i tried it did end up in frustration and I didnt touch it for a few month.

 

I have got several STM32VLDISCOVERY - Bords and a STM32F4DISCOVERY - Board.

My latest attemp was to setup eclipse with codesourcery, compile fof the SMT32F100 and debug with ST-Link (linux).

Setting up codesourcery and eclipse is not a problem, but i never get the projects right. I end up having tons of errors with the st-library or some other files....

 

Are there any preconfigured eclipse projects for the STM32VLDISCOVERY and the STM32F4DISCOVERY ?

I should be fine if it's not configured f0r st-link.

 

Thanks ... i'm really thinking about giving away my stm-boards if it's not gonna work soon.

Share this post


Link to post
Share on other sites

Thanks so far.

1: I got it running for the Stm32M4 dicovery kit. (I followed a german instruction ... the link's probably not very helpfull for non-german-speaking folks ;-) )

2: I did not get your template to run, it seems like you work on a windows pc ? When I switched the toolchain in the setting, all other settings were gone. (which is kind of understandable)

3: what's up with the st-link (the linux-version ) ? Debugging is quite painfull. It takes forever to upload a programm to the target device and debugging session crashes quite easy.

 

Actually my plan was to get everything running for the STM32M3 discovery kit (i got a few of them so why waste them?). There are more tutorials on the M4 so I tried myself and everything ended up in a mess.

No errors to post from here, i would have to start over step by step.

Share this post


Link to post
Share on other sites

I couldn't find Debian packages and I failed to compile the compiler :) The script was complaining about my gcc-version, it is looking for gcc4.4 and I have 4.7. I didn't try simply removing this version check.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×