Jump to content
43oh

Problem interfacing msp430g2553 with cc3200


Recommended Posts

Have you considered using serial?  I have an MSP430 connected to Serial1 on the CC3200 which leaves Serial to communicate with your PC if attached (I use it for debugging output).

The one issue I ran into - which may be your problem with I2C since it uses the same pins - the LEDs seem to screw things up.  I had to specifically set the green LED pin (RX 1) as an input to get things to work, even though I didn't have to do that for Serial - it was needed for Serial1.  I'm only receiving serial from the MSP430, not sending it back - but you might need to expressly set that pin as an output as well.   

Also - do you have pull-ups on the I2C lines?  Those are needed for I2C.  

Link to post
Share on other sites

They put up great pin maps at energia.nu - http://energia.nu/pin-maps/guide_cc3200launchpad/(http://energia.nu/wordpress/wp-content/uploads/2014/09/cc3200lppinmap.jpg for the full res image)

I believe you should be using 9 and 10 for SDA/SCL or TX/RX for Serial1.  It looks like 39/40 are alternates - but I don't think that's the default configuration.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...