Jump to content

CCS v6 Installs, but Continual "No USB FET was found" Error

Recommended Posts

I am new to CCS and am extremely frustrated in trying to make it work on Windows 7.  I must be doing something very wrong.


I have attempted to install CCS v6.0.1 three times on my Win7 machine.  I have turned antivirus off as well as Windows Firewall.  I installed it, connected my Launchpad EK-LM4F120XL to get a green power LED, and updated the software.  My device manager has always shown COM5 for the Stellaris Virtual Serial Port, and it also shows the two Stellaris ICDI devices (DFU and JTAG/SWD) as working properly.  I have tried different USB ports all with the same result.  I know the Launchpad is good because it works fine with Keil uVision4 (which I used for an online embedded class -- and I just compiled and programmed it with their blinking LED program to prove it is alive and kicking).  For CCS v6, I cannot get past the "No USB FET was found" error (FET is flash emulation tool from what I can tell) when I attempt to compile the Blink-the-LED sample program.


The error occurs when the compiler first runs the debug server (screenshot attached)...


Starting Debug Server ...
MSP430: Error initializing emulator: No USB FET was found


...and it occurs on every subsequent debug/compile as (screenshot attached)...


Error initializing emulator:
No USB FET was found


I am running CCS in "simple mode" to try to get this to compile the simple blinking LED example -- only this simple approach has failed.  I have googled this issue repeatedly and not found any solution.  I have spent a day installing, removing & cleaning files and the registry between installs, and rebooted.


What am I doing wrong?  How do I get CCS v6.0.1 to work?  Is there a setup parameter I am overlooking?  Help!







Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...