Jump to content

Launch4j An error occurred while starting the application???

Recommended Posts


Trying to update a customer of mine from E8 to E14 and get the Launch4J error message.


Have deleted preferences.txt  in ..\roaming\energia     Still got error.


Copied over preferences.txt from my PC , and after an edit regarding  sketch dir ,  it failed.


Turned off my WIFI in case Energia was getting trapped there. It still failed.


Will try E13 and see if that makes any inroads.


One suspect fact is that the customers PC has only 1G memory and cpu is an atom.  But as E8 ran ok on think that eliminates the netbook.

Link to post
Share on other sites

Got rid of the Launch4J error message, by moving all my libs from


"My Documents/Energia/libraries"


".. EnergiaE14/hardware/lm4f/libraries"


This means I will also have to move 430 libs into ../msp430 and also have to stuff around when E15 is released.


This solution is only a work-around and would like to find the root cause of the problem.

I have no Launch4J error  with my HP Envy, only on the netbook and feel that is where the actual problem is.

Link to post
Share on other sites
  • 3 months later...

Hi to all, 



I have the same problem on Windows 7 64 bit, E13 work weel, but when I download E14, and E15 when I started it only de error message apear (Launch4j An error occurred while starting the application). 


I try to delete libraries from  "My Documents/Energia/libraries" and the aplication started, I tried to copy the lbraries one by one and I found when in library folder exist exaple file ( *.ino) the aplications does not start.


In consecquence the solution is to delete/move all *.ino file from "My Documents/Energia/libraries" subdirectories. So worked for me.


I hope I helped.

Link to post
Share on other sites
  • 2 months later...

Help!! - Getting the Launch4J error message too


Running Windows 10 and cannot get Energia to run...

  • no spaces on the folder name
  • java updated
  • disabled the signed driver feature
  • disabled Bluetooth
  • installed the DPinst64.exe as administrator

Still nothing... I had this issue with release 14 on Windows 7 also.... I can run release 13 without any problems


I'm on a DELL I5-3 Quad Core Laptop with enough RAM and HD space


PLEASE HELP ME... I'm a teacher and need to be able to use Energia for my classes



Link to post
Share on other sites
  • 2 weeks later...

I'm still getting the Launch4j error message.

I'm running windows 10 and have tried all the suggestions listed above.


Does anyone have energia 16  running on windows 10?

Does a Launchpad meed to be connected to the USB port prior to launching Energia???


btw, I can run Energia ver 13 with no problem.


I've read that this is a Java related issue.  I have the the latest update of Java installed.


Any suggestions???

Link to post
Share on other sites

yeah!! success!!


simple find  the preferences.txt file in >>>>




I renamed the Energia folder in this directory as OLDEnergia


Then I relaunched Energia V16 from a shortcut I made to the desktop.  No need to run as Admin.


Once Energia 16 runs it makes a new preferneces.txt file in a new Energia Folder in the c:users\MyComputerName\AppData\Roaming directory


That's all :P

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...