Jump to content
Sign in to follow this  
bbtta

'No USB FET was found' using ccsv6 or msp430-gcc

Recommended Posts

Hi,

I have problems to communicate with my Launchpad MSPEXP430G2 using ccsv6 or msp430-gcc on Fedora 20. What I don't understand is that Energia transmits to the Launchpad normally (LEDs are already blinking...).

I followed step-by-step guides found on the net, create udev rules, finally switch to root to avoid wasting time on Linux stuff, but I still have the same error messages.

 

In the new TI/RedHat GCC (installed from the provided .run installer), when I connect GDB to the agent with the command 'target remote :55000', I get this message in the GDB agent:

MSP430 Client connected...Connecting to Target 
Couldn't find any connected USB FETs! Failed to initialize FET on TIUSB port.
Aborting. MSP430 Error :Could not find MSP-FET430UIF on specified COM port

In CCSv6 (installed with the .bin installer) , when I start debug, I get in the console:

MSP430: Error initializing emulator: No USB FET was found

As I said, I run these in root, and Energia is able to communicate and transmits to the Launchpad on the same computer.

 

Any clue to what I missed here? I tried to search web and forums with no results (even if I'm not confident with my searching skills...). Maybe I have to compile the toolchain from source instead of running the installer? I may try this next. I'll try next week on a Windows computer too. But I still don't understand why gcc and ccs can't do what energia can out of the box.

 

Tough to be a complete rookie.

Share this post


Link to post
Share on other sites

have the same error message on a fresh installed CCSV6 on Ubuntu 12.04. (I have energia working on this machine for some time now)

 

As of now:

- no luck with the G2 launchpad

- got the F5529 pad running with the following "procedure":

   1. do the blink example on a Win 7 box, let it do the update it asks for and all the stuff until it stops barfing 

       about required firmware updates, recoveries bla bla bla...    until the LED blinks

   2. plug it into the Linux box, click on the green Bug, then I get an error message about some firmware

       upgrade it thinks it needs:

 

 >Error initializing emulator: 
 >A firmware update is required for the MSP430 Debug Interface (MSP-FET430UIF / MSP-FET / eZ-FET). Click the "Update" button to  >update the firmware and launch your debug session (this may require several update steps).
 >DO NOT UNPLUG THE INTERFACE DURING THE UPDATE.
 
 
 
then I have to:
----------------------------------
CLICK ON IGNORE BUTTON HERE, OTHERWISE THINGS BREAK AGAIN !!!
----------------------------------
 
 
then it works. But this procedure breaks up things with Energia again.
And you guessed it, to fix it, you need Energia on Win 7 box, to do Firmware
upgrade there. 
 
What a mess.....

Share this post


Link to post
Share on other sites

Thanks for your feedback.

 

No joy here neither. And after a few days of resultless tweaking, I need to start playing with the MSP! So I installed CCS on my virtual Win7 and it worked right after install.

 

Not ready yet to leave Win! Linux could be so frustrating...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...