Jump to content

CC3200LAUNCHPAD upload failed via Energia, why?

Recommended Posts



I know Energia today and tried the example code "Blink" of Energia, but it shows "Upload failed.". More output is like below.

Binary sketch size: 4,128 bytes (of a 262,144 byte maximum)
Opening \\.\COM17
Getting storage list
Bootloader Version: 4
Silicon version ES1.32
Bootloader version is 2, 1, 4, 0
It's a CC3101 device: PG1.32
BlockSize is 4096, number of blocks is 64
erasing 1 blocks starting from  4
Switch to NWP bootloader complete
Silicon version ES1.32
Bootloader version is 2, 0, 4, 0
BlockSize is 4096, number of blocks is 16
erasing 12 blocks starting from  0

I flashed the Service Pack to my CC3200LAUNCHPAD Rev4.1, and tried CC31xx_CC32xx_ServicePack_1.0.0.1, CC31xx_CC32xx_ServicePack_1. and CC31xx_CC32xx_ServicePack_1., but still failed like above.

And I had connected SOP2-bottom with J8-top sides when using Energia.


Workaround: I can use Energia to compile, and use UniFlash to flash the image to the kit.


Could anyone help?


Link to post
Share on other sites

What is the part number that is written on the chip? If it is CC3200R1M2 or CC3200R1M1 then this is a new version of the chip and is not yet supported by the cc3200prog utility. We should be able to solve this next week and will provide an updated programming utility.


Also see https://github.com/energia/Energia/issues/507


Thank you very much for your feedback!

The issue is solved!

I have 2 CC3200LAUNCHPAD kits: Rev4.1 with CC3200R1M2 and Rev3.2 with XCC3200HZ. And just now I tried Rev3.2 by Energia and succeeded! But Rev4.1 failed, and the reason should be what you mentioned above.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...