Jump to content

Recommended Posts

Similar issue here with the MSP-EXP430F5529 development board.  My Windows 8 machine cannot recognize the driver in the device manager.

My other TI development boards work just fine.  This MSP-EXP430F5529 seems to have a weird driver requirement.


I tried almost everything. 

I downloaded and tried the MSPEXP430F5529UE 1_31_00_00

I upgraded CCS to the latest version. 

I tried using the .INF from MSP430WARE.

I rebooted Windows to accept unsigned drivers and that had nothing to do with it.


I called TI's support line and they were no help.  Furthermore they took my info down and promised to call back and they never did.


Any help would be appreciated.



Link to post
Share on other sites
  • Replies 33
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Off topic: I'm down for helping anyone out getting started in gardening or just any questions about it. Starting the Texas Master Gardener Program in 2 weeks.   On topic: If anyone is interested, I

Ok, Ok. TI gave me a full permanent license for CCS. After porting SimpliciTI to the MSP-EXP430F5529, plus my application, I maxed out the 16k license limit. Now I can have full range for all of the p

Well, I think I found the LCD HAL.   http://www.lcd-module.com/deu/disk/development%20service/DOGXL160%20UC1610/hello_world_DOGXL160_MSP430.zip

Posted Images

rcouto: the EXP5529 has a built-in SBW programmer, so you can use that with an MSP430 flasher utility of your choosing if simply your goal is to reflash.


On that note, make sure you are plugging-in to the correct USB.


Secondly, I have had issues with the EXP5529 board *hardware* myself.  There are some poorly design internal routes that seem to crack after some period of the normal poking-around that happens with dev kits -- word to the wise: use fatter traces for internal layers, as the copper is usually thinner and more frangible.

Link to post
Share on other sites

Hi jpnorair,


Thanks for the feedback.  I do have the board plugged on the EZ430-Emulation side with the power selection switch to eZ.

The board gets power and the preloaded demos work just fine.


I wanted to use the on board emulation/debugger.  Was not planning on using SBW.


If only TI had a driver that worked correctly under Win8




Link to post
Share on other sites

rcouto: the MSP430F5529 USB features are available through the USB port *not* attached to the programmer.


The programmer has a USB port, and all it is good-for is programming as eZ430 (eZ430 is a SBW programmer, by the way).


Moreover, there are internal traces in the board that get stressed by activations of the switch.  It's quite possible that you've broken the traces for programming.  To paraphrase Didier Drogba, the electro-mechanical design of the EXP5529 board is "a f---ing disgrace."  :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...