Jump to content

Serial Port Greyed Out on Macintosh

Recommended Posts

I am trying to upload a sketch but am unable to, as there is no way to set the port, as the Serial Port option is greyed out in the Tools menu.


I am running OSX 10.9.5, my device (CC3200 LaunchPad) is being recognised on the USB bus (see details below).


           USB <-> JTAG/SWD:


              Product ID: 0xc32a

              Vendor ID: 0x0451  (Texas Instruments)

              Version:  5.00

              Serial Number: cc3200

              Speed: Up to 12 Mb/sec

              Manufacturer: FTDI

              Location ID: 0xfa130000 / 6

              Current Available (mA): 500

              Current Required (mA): 500


I have tried installing the VCP drivers from FTDI. I am using the latest version of Energia.


Any other suggestions?



Link to post
Share on other sites

Energia & OSX & Serial (Port) is a little mess....

Have you read this?


and read this (arduino) thread about mavericks and ftdi:



A help for my Tiva TM4C123G Launchpad is, to start up energia with disconnected board and then (after start) plug in the device.

Link to post
Share on other sites

Just to make sure, have you installed the drivers that are posted on the energia.nu website here? http://energia.nu/guide/guide_macosx/

The drivers from FTDI will not work since the Product and Vendor ID for the CC3200 are not included in the standard FTDI drivers. The driver posted on the Energia website have been modified to recognize the CC3200. Make sure that you install these drivers.


Also make sure that you read through the rest of the guide here http://energia.nu/guide/guide_macosx/ and the guide for critical jumper settings here http://energia.nu/cc3200guide/


Link to post
Share on other sites

Thanks Robert, that sorted it out, I can now use Energia on my Macintosh.


Thanks also for the links to the guide, I will make sure I RTFM!


EDIT: Nice trick with the jumper cable....this will save me a lot of time, was getting quite annoyed with having to take the SOP2 jumper off and on.

Link to post
Share on other sites
  • 1 month later...

Hi I am running in to the same problem on mac. I have followed all the steps mentioned here. I got the board 2 days back. It says Rev 4.1 on the board.  I have installed the FTDI drivers from energia provided link. Restarted the machine. Made sure the jumpers are right. But still the same issue of Serial Ports being greyed out. If i unplug my cc3200 and connect my Tiva launchpad, energia has no issues in recognizing Tiva launchpad.


Only cc3200 seems to have issue. i am running energia version 0101E0013 on mac OS X Yosemite 10.10. 


Any ideas? 

Link to post
Share on other sites
  • 1 month later...
  • 4 months later...

I'm digging this topic out (apologies). Having issues with OSX now we're deploying our boards within the team with collaborators equipped with macbook computers.

Our CC3200 (mod) design doesn't use a FTDI chip but a silicon labs CP2102. We've installed the driver from silabs, it's signed. Other apps see the port without problem, they appear in /dev with tty. and cu. Obviously it's working just fine under windows.


We've tested this on OSx yosemite : arduino (1.6) sees the com port, max msp as well, but the serial port menu is greyed in energia 0015. The only moment we can see something in the serial port menu is when I plug an CC3200 launchpad (with the proper driver installed).


Normally, we should see there everything related to a com port, which includes the bluetooth port, or any USB uart, just like in arduino but that's not the case.

That seems to be the case in the wiki here, in the serial port selection paragraph



what are we missing ? Thanks

Link to post
Share on other sites

some more information about this : Energia 009 shows the ports properly and lists (like arduino) ALL serial ports including the BT port / modem, using the /dev naming (aka tty and cu).

for some reasons, it doesn't work the same since 010 or 011. I can't believe the serial port / peripherals could be filtered and that only "official" launchpad boards would be recognized, it doesn't make sense to me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...