Jump to content
madvoid

MSP430FR5969 Launchpad with Energy Trace on Mac

Recommended Posts

Hi all,

 

I've been lurking for a while but I finally joined up! I recently received the MSP430FR5969 FRAM Launchpad with EnergyTrace, and I'm trying to upload code to it with OS X 10.9.4 and mspdebug. I am successfully able to upload code to the standard Launchpad with the MSP430G2553 but I cannot upload to the FRAM Launchpad. Looking at this makes me think that a work around has not been found yet, is this true? Or has someone gotten the new FRAM Launchpads working with OS X?

 

Thanks in advance for any help!

Share this post


Link to post
Share on other sites

@@bobnova & zborgerd

 

Thank you for your reply! To answer both of your questions at once, I did try to update the EZ-FET firmware on the Launchpad by first pulling the libmsp430.so from energy, and then running mspdebug --allow-fw-update tilib. I even ran it three times as outlined here but each time it did not work, and did not let me upload.

 

I may try to compile the MSP Debug Stack for mac, but I do not know how successful I will be.

 

Thanks again!

Share this post


Link to post
Share on other sites

@@bobnova & zborgerd

 

Thank you for your reply! To answer both of your questions at once, I did try to update the EZ-FET firmware on the Launchpad by first pulling the libmsp430.so from energy, and then running mspdebug --allow-fw-update tilib. I even ran it three times as outlined here but each time it did not work, and did not let me upload.

 

I may try to compile the MSP Debug Stack for mac, but I do not know how successful I will be.

 

Thanks again!

 

I think that Energia will get an update soon.  If you want to compile the library, you may be able to do it with hidapi and libboost.

 

You may be able to loosely follow the Linux instructions here:

 

http://forum.43oh.com/topic/5706-use-mspdebug-to-upgrade-msp430fr5969/

http://www.colotronics.blogspot.com.ar/2014/08/msp430-toolchain-in-ubuntu-1404-with.html

 

Be aware that even if you can flash the board, you may run into problems with corruption and other issues that I've mentioned in other threads,.  I guess that using TI's MSP-GCC-ELF compiler might resolve some of this as well as using a patched version of mspgcc, such as the version included in Energia.  I've had to debrick my board with a BSL flash no less than 5 or 6 times so far, but I'm using the old MSPGCC  LTS 20120406 because I still trust it more than RedHat / TI's GCC compiler.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...