Jump to content
Sign in to follow this  
Frida

Use mspdebug to upgrade msp430fr5969

Recommended Posts

I followed an instruction from:
http://www.colotronics.blogspot.com.ar/2014/08/msp430-toolchain-in-ubuntu-1404-with.html

Down the page:
# OPTIONAL TILIB v3 installation of msp fet430uif debugger, ignore if you do not have it

I also need to install
sudo apt-get install libusb-1.0

Then I have to do mspdebug tilib --allow-fw-update several times. Maby as su.
Now it sees my msp430fr5969 Launchpad with EnergiTrace.
Now I think the fun starts!

 

Share this post


Link to post
Share on other sites

It happens to me also, I have to do

mspdebug tilib

several times before a connection is established with the debugger. I don't know why, but doesn't represent a huge problem neither.

This is a screenshot of the errors:

 

Screenshot+from+2014-07-20+22:05:27.png

 

After several of those the communication is established normally, without doing anything in between other than execute mspdebug tilib.

In fact, the last message is a normal initialization, but I don't have any msp430 connected to the debugger, thats why error = 5.

 

If the udev rules are defined you don't need to use su.

The allow-fw-update thing is needed one time only, after the installation of TILIB on the PC.

 

I will add the libusb-1.0.0 dependency, thanks for the observation :thumbsu:

Share this post


Link to post
Share on other sites

The allow-fw-update thing is needed one time only, after the installation of TILIB on the PC.

I had to do it several times, maybe because I had tried so many other things without success.

So now I having fun with Launchpad msp430fr5969 and the UECIDE.

Share this post


Link to post
Share on other sites

So I built a new tilib and the board is fine with all of my tools.  Unfortunately, I've been running into a lot of problems with FET corruption on this FR5969LP board and also the 5529LP.  The flash ultimately fails on Linux but seems to recover on a Windows machine with the flasher utility.  But now that I have the FET fiwmare up-to-date, everything seems to work well.

Share this post


Link to post
Share on other sites

Pretty sure that this new release of tilib is mandatory.  I have an older version and this board reports as unrecognized.  Going to update it later.

 

Ok, I modified slightly the optional sentence ^_^

 

So I built a new tilib and the board is fine with all of my tools. 

 

Nice to know. I did a lot of things before arriving to a valid build of the whole toolchain, due more to my lack of knowledge than the process itself. Hopefully I can save somebody time and nerves

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...