Jump to content
43oh

Simple Web Server: MSP430F5529LP with CC3000 Boost


Recommended Posts

Hi,

I am following this video to create a simple web server on MSP430F5529LP with CC3000 Boost, with Energia version 11.

 

The output of the serial monitor is attached. 

 

When I access the server IP (http://192.128.1.68/) from the browser, the page doesn't load. 

 

The boost IP doesn't seem legit. Look at the attached output and you will see the gateway is 192.128.1.254 but actually the gateway is 192.168.1.254 (got from cmd prompt ipconfig result).

 

Similarly, the boost IP should be 192.168.1.68, not 192.128.1.68. Tried both in the browser but none works.

 

It seems like my CC3000 Boost is not properly configured. 

 

Can anyone please suggest?

 

post-37713-0-71390400-1404435286_thumb.png

Link to post
Share on other sites

Hi LilyHack

There is another example sketch in the SimpleLinkWiFi folder called "CC3000FirwareUpdate". Go ahead and flash this example into your LaunchPad while the CC3000 WiFi BoosterPack is plugged in.

 

This sketch will update the firmware of the CC3000 WiFi BoosterPack. Once the sketch if flashed & the red & green LEDs of the F5529 LaunchPad start toggling, that means the firmware has successfully updated!

 

Now that the CC3000 WiFi BoosterPack is updated to the latest firmware, go ahead and try the Simple Web Server example again. Hopefully that fixes the issue! Good luck!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...