Jump to content
Sign in to follow this  
dirtyHippy

MSP430FR5969 Launchpad & OS X

Recommended Posts

I'm trying to program my MSP430FR5969 Launchpad from OS X Mavericks 10.9.3 and am having some trouble. All the instructions that I can find are rather old, so I don't know if Mavericks is the problem, or if this USB driver I'm using doesn't support the 5969, or what. When I run 

mspdebug rf2500

I get the following output:

usbutil: unable to find a device matching 0451:f432

The following appears in Console after attaching my Launchpad:

5/23/14 6:57:35.000 PM kernel[0]: MSP430LPCDC : Quiting : Not Launchpad

Does anyone have a suggestion on what I could do to make this work? Is Linux development more stable? I could just run a VM, though I'd greatly prefer to avoid Windows.

Share this post


Link to post
Share on other sites

Thanks for the tip! I had to run 

mspdebug --allow-fw-update tilib

3 times (getting a different error each time) before it worked, but it eventually came though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×