Jump to content

Serial Monitor/Serial.print() issue

Recommended Posts



new guy here. I can't get it to write aswell :/


Just trying something super basic for the first attempt:

void setup()
void loop()
  Serial.print("Hello World");

COM is detected by both windows and Energia, it compiles without errors and the baud rate is set in the serial Monitor, tried to change the pins on J3 ( horizontal and vertical positions) and PuTTY incase the inbuilt Energia monitor was the problem. NOTHING. can't get it to do it. I got some basic led flashing in another code running, so the chip isn't dead and i also tried it on two computers with both usb3 and usb2 sockets.  the USB cable that i use is 1.8m long but i refuse to believe that it could be the cause.

Share this post

Link to post
Share on other sites

I have a strange problem with my MSP430G2553 Serial Monitor. It is rev. 1.5 so I did change the UART pins to vertical, but whatever I want to post to serial monitor I get some random symbols (like it would do when the baudrate is wrong). How do I know that everything with baudrate and COM is right? I have two MSP430G2553 and the other one works with no problems at all. Maybe I need to reset something or whatever? I have no idea what to do other than change the MSP430 for another one. Thanks.


Edit: I just changed the MSP to another one which worked.

I asked my professor about this and he said it is due to some frequencies in the controller itself. Had no time to go in depth with solving the problem with the controller.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now