Jump to content
43oh

MSP432 Launchpad Serial Monitor stopped working after Windows 10 upgrade


Recommended Posts

It seems after a Windows 10 upgrade the serial monitor does not work for Energia 1.8 for the MSP432.  Looking at the EVENTS in the Device Manager shows the serial port is not migrated, but the device properties says the COM port is working properly.  I have reloaded the XDS110 drivers and get the same results.  The serial monitor function was working properly until Windows was upgraded.  (Windows 10 Pro version 1909).  I have tried many of the Regedit solutions suggested to get a device to properly migrate to no avail.

On another laptop I used an older version of Energia 0101E0017 and Windows 10 Pro version 1903.  The MSP4302553 serial monitor worked fine, but the MSP432 serial monitor did not work even with that older version of everything.  Unfortunately that negates my earlier statement that the MSP432 serial monitor was working until an upgrade to Windows occurred.

Just wondering if anyone else has had this problem and how they solved it.

 

Here is my simple checkout code for the Serial monitor function:

void setup() 


//  LED colors on Luanchpad board
  pinMode(75, OUTPUT);      // Red
  pinMode(76, OUTPUT);      // Green 
  pinMode(77, OUTPUT);      // Blue
  
// Turn off LEDS

  digitalWrite(75, LOW);
  digitalWrite(76, LOW);  
  digitalWrite(77, LOW); 

  Serial.begin(9600);          // start serial communication at 9600bps

  Serial.print("Made it to Setup");
  digitalWrite(75, HIGH);        // Red LED
  delay(250);
  digitalWrite(75, LOW);        // Red LED
  delay(250);  
  digitalWrite(75, HIGH);        // Red LED
  delay(250);
  digitalWrite(75, LOW);        // Red LED
  delay(250);  

 
 
void loop() 

   Serial.print("Made it to Loop");
   digitalWrite(77, HIGH);           // Blue LED
   delay(250);
   digitalWrite(77, LOW);           // Blue LED
   delay(250);   
   digitalWrite(77, HIGH);           // Blue LED
   delay(250);
   digitalWrite(77, LOW);           // Blue LED
   delay(250);
  

    End of Post

 

Link to post
Share on other sites

Some more information on this issue.  I tried running my MSP430 Launchpad on the "new" Energia and Windows 10 combination.  The program compiles and uploads without errors, but if I use the serial port it completely locks up my computer and I can only reset the entire computer to recover.  This exact same MSP430 Launchpad worked just fine with the serial port on an older Energia and Windows version as mentioned in the first post.

Most perplexing.

 

Link to post
Share on other sites

Just in case anyone is interested this problem has been resolved.  I purchased a new MSP432 Launchpad, it is Rev 2.1 versus the previous Rev 2.0 I was using.

I found the link to the "out of box GUI" (which was not straight forward the location is NOT where the documentation with the LaunchPad indicates) and ran that from the Cloud, it worked just fine.  To me that proved the serial port was communicating both ways.  I then loaded my simple check out program and it worked just fine.

I then plugged in my Rev 2.0 MSP432 LaunchPad (which used to work just fine) and uploaded the same check out program.  It did not work, but I get no error messages at anytime.  

When I plug in my new MSP432 Rev 2.1 the simple check out program still works.  I have no idea what is the cause for the solution.  

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...