Jump to content

Can't flash the MSP430 with Launchpad - stuck at step 0 :(

Recommended Posts



I can't get the flashing/downloading/running part to work. I always

get the error message:



Failed to load program MSP-EXP430G2-Launchpad.out' on any of the





The target 'TI MSP430 USB1/MSP430' could not be found.



So I (randomly) fiddled around with the IAR WorbBench, and (although i

did get some error warnings about hardware mismatches), it did seem to

do something, and at the very least deleted the temperature-sensing

demo program (although the blinking program isnt working, now). Thus,

i'd guess that the Launchpad board is communicating in some form with

the MSP.


Any pointers on how to get this (or anything at all!) to work with

CCS? I really want to climb this admittedly steep learning curve, but

can't even get over the first hurdle! :(


Is there a 'raw' way (CLI) of flashing the chip? Just to test whether

maybe my eclipse config is screwed up, or to check whether the board

is fried?

Link to post
Share on other sites

It sounds like the TI drivers for the Launchpad are not installed yet.


You should verify that your PC can see the LP in the Device Manager as a TI Comm Port.


Assuming you're using Windows:

- Press "WindowsKey R",

- Enter "devmgmt.msc"

- Expand "Ports (Com & LPT)"


Do you now see "MSP430 Application UART (COM)" where is some number like "3"?


If you don't see that then you have to plug in the Launchpad via a USB cable and press the F5 key in the Device Manager. That will cause the DM to refresh its list of devices.


If the DM can't see the LP then your LP is most likely dead in the USB sense. :x


If this is the case then this is the first time I have heard of an LP dieing and we're sorry for your loss. :(


If you can see the LP then you're in action! :D


If you want to use a different method to check out your LP then go get this program from Elpotronics. Install it. Fire it up. See if it can see your LP. If so then you're in business. If not then we weep for the loss of your LP :cry:


Let's hope for the best. :)

Link to post
Share on other sites

I have had the drivers installed (although i do think TI is wrong to include them in those gigantic downloads of IVR and CCS!), so that can't be the issue in this case.


The temperature demo program was working ok before - serial communication and all. Although that program isnt there anymore since my (failed?) IVR WorkBench flash. This flash is what tells me that the LP itself should be working fine, since the IVR program did detect the MSP, and said things like 'erasing memory....'. It's just that I cant get CCS to do this, and all tutorial are CCS based.




Link to post
Share on other sites

If you haven't already, then get all the basics out of the way. Try using a different cable, a different usb port, and, if all else fails, a different computer. If it's still not working then you have a problem with your launchpad :(


BTW, if it helps you to know, the launchpad won't communicate to the computer if the msp340 is fried. If you think you may have allowed one of the connections on the bottom to be shorted by a wire or other metallic object, then replace it with the msp340g2211 that came with your kit.

Link to post
Share on other sites

Hi, again, and thanks for the suggestions!


I was following the instructions at:

http://www.msp430launchpad.com/2010/07/ ... arted.html


which seem to be straight-forward enough.

Yet, i got the error I described in my last post - but if I simply use the example project, without ANY modifications, and click on 'debug', after a while i get the error:


MSP430: Error connecting to the target: The target setup (F20x2_G2x2x_G2x3x) does not match the actual target type (F20x1_G2x0x_G2x1x)


....which i then 'ignore', and CCS happily flashes my MSP430. When I click on 'run', the leds start blinking again. The program doesn't seem to run, though (i guess because of that target mismatch).

If I use exactly the same project, and simply change the target from the pre-defined 'MSP430F2012' to the chip i am actually using (the 2211, in this case but i also tried it with the 2231), i get the message mentioned in the other comment, again, an nothing works at all.


The EXACT same thing happens on another computer with a different USB cable.


I did update the firmware of the launchpad before even starting to try all this, so maybe it has something to do with that.



Link to post
Share on other sites

When you make a new ccs project you need to make sure you select the correct chip you are using, such as the 2211 or 2231. Also, you must realize that the 2211 doesn't have a built in thermometer, so using the 2231 demo code on it won't work right.

Link to post
Share on other sites

This is something that frusterates me about the launchpad a great deal, I get these errors (and others) randomly when I'm trying to debug or load code onto my project, I have to as others have said, unplug it and plug it back in, sometimes even on a different USB port.


I also have a problem (and i'm guessing this is something with he windows driver) where the serial will just stop outputting any data until I reboot the computer, unplugging the launchpad or switching its USB ports does nothing...


I really think its just buggy drivers.

Link to post
Share on other sites

Sometimes, the PC shuts off a USB port that starts acting bad.


Specifically, if the target USB board takes more than 500mA of current then the motherboard will shut off that USB port until you either reboot the computer or deactivate then reactivate that port in the Device Manager.


I don't know what's happening in your case but your LP could be taking too much current or your Code Project is setup for the wrong type of MSP.


Just some random thoughts.

Link to post
Share on other sites
When you make a new ccs project you need to make sure you select the correct chip you are using, such as the 2211 or 2231. Also, you must realize that the 2211 doesn't have a built in thermometer, so using the 2231 demo code on it won't work right.


yea - the temperature program flashed and runs perfectly on the 2231 now, but that isn't really my issue.


My problem is, that if i double click that ccxml thingy on the left, and change the target to the chip i am actually using, CCS refuses to see the chip. If I leave it exactly like it is right in the example project (which has a 'wrong' chip selected) it detects a target mismatch, but at least sees the chip, and then flashes it.


But it just seems wrong using the wrong configuration, even if it works. But any other target makes CCS go blind. On two seperate PCs.


hmmm....come to think of it - maybe it's not the bad configuration per se, but the clciking on the 'save' button that screws things up. because if i change it back to the initial, wrong selection, CCS still refuses to detect the chip. I will try to change the XML by hand, to see what happens.

Link to post
Share on other sites
You should be changing the target for the whole project:

Right click on the project folder -> Build Properties... -> CCS Build -> General

This will update all necessary files, like linker cmd file.





That worked! No mis-match warnings, no device-not-found errors, no nothing!



Thank you!

Link to post
Share on other sites

You are welcome.


Also, this is where you could change some other things like assembler options.

The one I am using, which helps me in troubleshooting, is enabling .asm output file.

Right click on the project folder -> Build Properties -> C/C++ Build -> Tool Settings -> Assembler Options (under MSP430 Compiler)

There, check "Keep the generated assembly...," "Generate listing file," and select Generate C source interlisted..." in "Source interlist" drop down.

The only option that would be useful and looks like it's missing is "--absolute_listing"

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...