Jump to content

Recommended Posts

Setup :


Portable PC

Windows XP

Launchpad MSP-EXP430G2 Rev 1.5  Board

Program : Eamples/Basic Blink

Compiler : Energia

Board : Launchpad w/ MSP430g2553

Serial Port : Port 3

Processor Fitted to Board : M430G2553



I downloaded the Energia compiler today and tried to run it for the first time with the setup above .


Compilation ok until I got the following linker error


c:/program files/energia/energia-0101e0011/hardware/tools/msp430/bin/../lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld.exe: cannot open linker script file memory.x: No such file or directory
collect2: ld returned 1 exit status


 It looks like it cannot find the memory.x script file .  


I found a memory .x file in the following directory -  


C:\Program Files\Energia\energia-0101E0011\hardware\tools\msp430\msp430\lib\ldscripts\msp430g2553


I compiled it into the same path as the linker -  C:\Program Files\Energia\energia-0101E0011\hardware\tools\msp430\msp430\bin


I still got the same error  . For some reason the linker is not finding the memory.x file it seems


Aslo, I think the  Com ports are not  seeing Launch Pad board. I get the same Com port list when I select Tools --> Serial Port  when the LaunchPad board is plugged in and when it is unplugged .  Ther are no Com ports on this portable PC normally .


Anyone know what I can do to resolve this issue ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...