Jump to content

CC3000 on MSP430F5529 with Energia

Recommended Posts



I found the following YouTube video demonstrating a web server using the MSP430 CPU and the CC3000 Wi-Fi module, together with the Energia toolchain. 


The video is at http://www.youtube.com/watch?v=1yBP8HwUyeo


The evaluation modules recommended in the video are the


MSP-EXP430F5529LP launchpad evaluation board http://www.ti.com/tool/MSP-EXP430F5529LP

With the CC3000BOOST booster module http://www.ti.com/tool/cc3000boost


I got the parts and connected them. Got the energia toolchain and compiled and downloaded the simpleWebServer example.


through the serial monitor provided by energia I got the following:


Connecting to WiFi....
Connect success!
Waiting for DHCP address
IP Address Information:
IP Address:
MAC address: 70:FF:76:01:75:CD
Version: 1.10
ret: 171
Google IP:
new client
GET / 
When trying to access the web server through the browser by using I got the 'new client' string and the GET cmd...
but the page described in the video never popped up...
Is the example included in energia-0101E0011 unfinished... if so is there a new version? Any hint as to what I may be missing is greatly appreciated!



Link to post
Share on other sites

Hi Nick, now that my simple server is working for WPA... my next step is to make it work for WEP...


I changed:


WiFi.begin(ssid, pass);                 // for WPA APs




uint8_t key_idx = 0;

WiFi.begin(ssid, key_idx, pass);   // for WEP APs 


this experiment did not work... so I started following the code and I ran into a little confusion since the function:


wlan_connect(WLAN_SEC_WEP, ssid, strlen(ssid), NULL, key, key_idx);


called by WiFi.begin appears to interpret the parameter key_idx as the length of the password? not as the key index...


so I changed key_idx to be the length of pass... and this experiment did not work either...


Ideas and suggestions welcomed....







Link to post
Share on other sites

Sorry Diego, i've never bothered connecting to a WEP AP since my network is WPA.

And by the way, WEP is considered unsafe and easy to hack, with a modern laptop in a matter of minutes according to security websites.


But nice to read that you've got it working in WPA mode. :)


regards, Nick

Link to post
Share on other sites

Hi Nick, thanks for your reply. The WEP mode is required as part of the board evaluation process ... I understand its weaknesses :-) ... can you redirect me to someone that could help with the WEP mode for this sketch?







Link to post
Share on other sites

If i remember right WEP consisted of either of 4x 40Bit keys or one 128bit key, so i suspect that key_idx specifies which of the 40bit keys is meant, i also remember that WEP keys were hexadecimal.

I tried for an hour to connect to an old router with WEP but didnt succeed either, perhaps you can find some tips on Ti cc3000 wiki.



regards, Nick

Link to post
Share on other sites
  • 3 weeks later...

Hi all


I was able to connect the two things combo to my wifi (after some software upgrade on Energia with MSP430 "drivers"), with and without WPA or WEP protection (just comment/uncomment the relevant lines), but after the successfull connection I can't access the web server page using the assigned IP, after some time the browser gave up.


Any tips ?


Link to post
Share on other sites

Try pinging the webserver. Even if the program has crashed the cc3000 replies to ping packets, looks like pings are handled by the cc3000 itself.

Open a command shell (on windows click on start button and enter "cmd" without quotes in the search line)

in the commandshell type:

ping <the ip of the webserver>


When you get a respond this means the cc3000 connected correctly but the program has probably crashed or isnt handling requests correctly.


Can you post the serial output? please edit out your wifi-password if that is showing up in the serial console before posting.


regards, Nick

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...