Jump to content
43oh

Energia 0101E0011 and COM Port problems


Recommended Posts

I tried searching for likely topics, admins feel free to move it to a more suitable Topic

 

Hello, I hope someone can tell me how to get out of this situation:

 

Windows 7

Energia 0101E0011

MSP430G2553 

 

YES I have the drivers installed!

 

Lately I've been seeing this more and more

 

I'm flailing away trying to upload my sketch. (Used to work okay)

 

I make some changes (often), yes it compiles ok but hangs on upload

 

I use Control-M to upload and open serial monitor (my preferred method but none seem to work now)

 

The progress is displayed below the actual sketch in Energia.

 

It will get to Erasing...Programming...Done, 3184 bytes total. 

 

Done uploading, it tells me BUT

 

The Upload button in the tool bar at the top stays yellow

 

eventually I get this message below

processing.app.SerialException: Error opening serial port 'COM5'.at processing.app.Serial.<init>(Serial.java:152)
at processing.app.Serial.<init>(Serial.java:92)
at processing.app.SerialMonitor.openSerialPort(SerialMonitor.java:209)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2525)
at java.lang.Thread.run(Thread.java:619)
Caused by: gnu.io.UnsupportedCommOperationException: Invalid Parameter
at gnu.io.RXTXPort.setSerialPortParams(RXTXPort.java:171)
at processing.app.Serial.<init>(Serial.java:137)
... 4 more
 
this is driving me nuts! It used to work (most of the time)
 
When I get messages like this, and it fails to upload my sketch, I pull the USB, powering down the board, close Energia, 
 
open Energia again. Checking Tools>Serial Port, either I have a COM Port selected or its grayed out.
 
I repeat the above steps again and again. MAYBE I'll have a COM port selected. I can't choose one, have to accept whatever appears (or does not appear)
 
How can I debug my code if it won't even upload?
 
Please help. Thanks

 

PWM_01.ino

Link to post
Share on other sites

I was hoping to have received some replies by now. 

 

I tried removing and reinstalling (downolading and unzipping Energia 0101E0011.  Did not help.

 

I tried different USB cords. Did not help.

 

Seems to me the problem is in Energia, not my hardware.
 

Has anyone stumbled upon a work-around for this very annoying issue?

 

 

Help help. 

 

 

Link to post
Share on other sites

Maybe the Launchpad has a brownout during flashing. I think during flashing the launchpad draws a lot of power from the usb port. If your usb port or you psu is flaky i think this would be the point when failure has the highest probability. Have you tried a different usb port, perhaps a powered usb hub, or if youre using a hub to directly connect the launchpad to a port at the back of the pc, those have the shortest connections to the power planes of the motherboard.

 

regards, Nick

Link to post
Share on other sites

A friend locally also suggested that the problem might be my USB port.

It does seem one of the front ones is less problematic than the other in this situation.

I was thinking perhaps "noisy" power or signal, but brownout

never occurred to me.

Do these things take a lot of current to flash?

I'll certainly try a powered USB hub and/or as Nick suggests, a cord directly to a USB port on the  back of my desktop.  

I can understand about the long ribbon cabling connecting these front USB ports to jacks near the back side of the motherboard -- and routed past some potentially noisy stuff come to think of it...

Good ideas!  Thanks and I'll let you know if that helped.

Link to post
Share on other sites

I do most of my work using Linux, but often see similar behavior. Also, it seems after a while the whole interface will quit working to the point that a reboot of the PC is the only fix.  Lately, I have been using a USB-TTL converter (commonly called an FTDI, but mine are Prolific) wired to the P1_1 & P1_2 pins with the RX/TX jumpers pulled. This way I can program from Energia and use Putty to monitor the serial traffic without having to constantly open/close the serial monitor, seems much more reliable and works at higher baud rates.

 

The performance of the Launchpad ACM interface is probably my greatest disappointment with the Launchpad, especially when I compare it to the Arduinos and Stellaris boards I have worked with. I have seen answers on the TI forums claiming OS problems as the cause, but why do the other boards not suffer?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...