Jump to content

[SOLVED] Problem with UART on M430G2553

Recommended Posts

Hi I'm new with energia and I'm trying to use the Hardware serial communication with a Lauchpad Rev. 1.4 so I connect the RX end TX jumpers in cross but it doesn't work...Can anyone help me? this is the simple code I use:


void setup()  
void loop() 
   Serial.println("Hello !!!");



I try to use also the software serial communication for but it doesn't work 

Link to post
Share on other sites
  • 2 weeks later...

I'm using Windows 8 pro 64 bit with the MSP430FR5739 LaunchPad and cannot see serial traffic on a terminal. About 1/100 times when I connect to USB I *will* see serial traffic, but that's about it.


My MSP430 Application UART driver is version, I have tried COM ports 1 to 13 with no noticeable improvements. The LauchPad drivers .zip file has DPInst, USB_CDC, USB_eZ-RF, and USB_FET_Win7_64 directories. I can't seem to just run the DPInst64.exe file in its directory, but if I copy DPInst64.exe to each of the aforementioned directories I will get these different drivers in each directory installed. I'm not sure if this is the right way of going about it?


Any ideas what is going on? Code 'uploads' pretty consistently to the MSP430 with occasional hiccups where I have to retry but the serial communication interface never really works.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...