Jump to content
43oh

install Energia on mac os X 10.6.8 For MSP-EXP430F5529LP


Recommended Posts

Hello

I'm not sure where to post, so I do it here, please feel free to give me the correct topic to go to, Sorry !-)

 

I am new to MSP-EXP430F5529LP and Energia.

 

I tried to install Energia 0101E0010 following the getting started webpage (http://www.energia.nu/Guide_MacOSX.html).

Everything looks correct but Serial Port is grey, no ways to get it...

 

So, I tried to install 0101E0009.

Here, Serial ports are looking correct (although I have 2 potential candidate ports that I have seen nowhere in the topics on this forum:

/dev/cu.Z530i-SerialPort-1 or /dev/cu.Z530i-Dial-upNetworking-2, or the corresponding ones with tty instead of cu), but

the MSP-EXP430F5529LP is not on the list of available boards...

 

Could anyone help?

 

Thanks a lot

Pablo

Link to post
Share on other sites

There is nothing wrong with your installation of Energia 0101E0010. The issue is that I messed up in the IDE code by assuming that al version of OS X present the serial port as tty.uartXXX, tty.usbmodemXXX or tty.usbserialXXX. Obviously this is not the case for your system.

 

The way around this would be to create a symbolic link called something like /dev/tty.usbserial123 to /dev/tty.Z530i-Dial-upNetworking-2.

The Serial port of interest is always the highest numbered. So if you see entry /dev/cu.Z530i-SerialPort-1  and /dev/cu.Z530i-SerialPort-2 then /dev/cu.Z530i-SerialPort-2 is what you want.

sudo ln -s /dev/tty.Z530i-Dial-upNetworking-2 /dev/tty.usbserial123

Note that the /dev/tty.Z530i-Dial-upNetworking-2 entry could change name when you unplug/plug the LaunchPad.

 

When you restart Energia you should see the Serial port show in the menu.

 

Regardless of the Serial port. You can still program the board since it does not rely on the serial port for programming.

 

Robert

Link to post
Share on other sites

Hi

Sorry I think I was not clear enough:

 

With Energia 10: I can't acces serial ports at all (same situation as post http://forum.43oh.com/topic/4626-no-unused-fet-found-mac-os-x-1068-f5529/ )...

 

With Energia 09: I see the entries but anyhow, the MSP-EXP430F5529LP board is not in the list...

 

So for the moment, not possible to have any programm sent to the board...

 

Thanks for your help

Pablo

Link to post
Share on other sites

Hi

 

Good news.

 

I installed again MSP430LPCDC 1.0.3b,

restarted with MSP-EXP430F5529LP plugged (don't know if that has any importance or not),

started Energia 10 again and

 

Serial port is there!!!

 

Well in fact it's not good news: I had my arduino uno plugged as well, and when unplugged, serial again unavailable...

Sorry

 

Thanks

Pablo

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...