Jump to content

Ez430-Chronos + CCS, Getting started.

Recommended Posts

So, in last week's deal i got one Ez430 Chronos watch.

Installed the last CCS, got almost a day of infrutiferously reading the e2e community reports on how to correct the **** path error on "C:\ti\ccsv5\msp430\include"..  I ended up finding by miself these files were relocated to C:\ti\ccsv5\ccs_base\msp430\include. 


So i took the easiest way and just duplicated the whole folder to the place where ccs was looking for it. (didn't found out how to change this in CCS, and somewhere i read that it was a eclipse bug, so i decided not to discuss with ccs and do what it wanted).

I was able to get the examples imported and compiled. Woohoo!!!



Now, i have no idea how to backup the information memory, so i don't mess with the calibrations. Anybody knows of a TI note on doing that?


Thank-you very much for the attention, and i hope that helps anibody who runs in the same path invalid thing.  Took me almost two days to fix ><"

Link to post
Share on other sites

It does look like Elprotronic's FET-Pro430 program can do this.




Look for "FET-Pro430 Lite Software ( FREE )"


With the program opened, it looks like under Setup > Memory Options > Read Address Range, you can define what you want to save.


Note: I have not actually tried it. Might be a good idea to wait for someone more knowledgeable to chime in.

Link to post
Share on other sites

It works quite nicely! First you have to configure the fet to work, select the correct usb address, 2-wire(spy-by-wire), and then the hex pops out! I took some prints, inspired by a guide from the metawatck wiki.


First go to config menu:

Then select 2-wire (the only supported by the launchpad), for the Ez430+Chronos, any of them will work; then select the usb debugger (Auto doesn't work for me)

1-2-3, the order is critical, no need to select any files, mine had one selected from anterior work.  If check security fuse fails, wether something is not configured right, or the chip is protected :( .

If everithing went good, when you click read memory a window with the hexas should pop

Link to post
Share on other sites

How are you working around the code size restrictions for the Chronos with CCS?


I bought one in the recent deals and am totally frustrated that I can't compile the full firmware although I am using the IAR Workbench. I havent tried CCS yet because I understand that the crippleware problem is the same.


I'm now looking at Energia and mspgcc for the chronos. I also have Stellaris Launcpads and an EXP430G2 launchpad and want one dev environment for all 3.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...