Jump to content
43oh

[SOLVED] Cannot get Serial communication to work with Launchpad 1.5 and MSP430G2553


Recommended Posts

I am just trying to do something extremely simple, such as:

void setup(){
  Serial.begin(2400); 
}

void loop(){
  Serial.println("TEST");
}

Yet it does not work. I have rotated the RX/TX jumpers and it doesn't help, selected the correct board in Energia, selected the correct baud in the serial monitor and nothing ever shows up. Nothing is connected to my Launchpad.

 

I am using Windows 7, I have also tried running as administrator.

 

Does anyone have any idea what could be causing this? I am currently installing CCS to see if it would work in it.

Link to post
Share on other sites

I did not have the drivers installed. I have them installed now and it seems to have helped a little - an extra COM port is showing up now, and the serial monitor is showing things - although those things are garbage.

 

Edit: Nevermind, I had the wrong baud this time. It works!

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...
  • 3 years later...

// Core library

#if defined(__MSP430G2553__)

#else

#error Platform not supported

#endif

 

#include "Thermometer_430.h"

 

Thermometer_430 myThermometer;

 

void setup() {

  pinMode(PUSH2, INPUT_PULLUP);    

  myThermometer.begin();

  Serial.begin(9600);

  Serial.println("Thermometer");

  Serial.println("press PUSH2 to exit serial");   

}

 

void loop() {

  myThermometer.get();

  Serial.print(myThermometer.temperatureX10()/10, DEC);

  Serial.print(".");

  Serial.println(myThermometer.temperatureX10()%10, DEC);

  if (digitalRead(PUSH2)==LOW) {

    Serial.println("exit");

    Serial.end();

    while(true); // endless loop

  }

}

 

 

 

Nothing show up ... help please.  

Link to post
Share on other sites
  • 3 weeks later...

What LaunchPad are you using? ...................................................................................................... MSP430G2553LP v1.4


What operating system? ................................................................................................................... Windows 8.1


Did you install the required drivers according to instructions on http://energia.nu/guide/ ? .............. Yes.


Can you see a new serial port appear when plugging in the LaunchPad?  ...................................... Yes.


Link to post
Share on other sites

Did you cross the serial lines as documented in the pinmap?

 

Note that version 1.4 is different from 1.5.

http://energia.nu/pin-maps/guide_msp430g2launchpad/

Somehow, when I posted a similar remark (the OP's photos indicated the wrong jumpers may have been set), it somehow ended up the new users "say hello" section.  How I managed that is a mystery... So it goes. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...